[CalendarServer-dev] cannot authenticate with server

Tim Lynch tjl3 at cornell.edu
Mon Nov 13 12:14:30 PST 2006


oops,  forgot to send as plain text ...


Hi,

I am trying to run CalendarServer on Mac OS X 10.4.8 ...

I downloaded from SVN, and followed the quickstart directions on the wiki.

When I ran 'run -s' for the first time, patching hung when trying to 
patch resource.py.  I applied the patch manually and that seemed to work OK.

I copied repository-static.xml to repository-dev.xml and made one 
change:  I changed the passwd for admin.

Then, I ran the server with './run' and it seemed to work.  However, 
when I try to connect at 127.0.0.1:8008, the browser's dialog box says:

   Enter username and password for "" at http://127.0.0.1:8008

I assume the empty quotes mean no principal was identified, right?

And then, no matter what I enter for username/password the server spits out:

Could not find principal matching user id: admin
2006/11/13 12:04 -0400 [HTTPChannel,1,127.0.0.1] 'Invalid authentication 
details:
[Failure instance:
Traceback: twisted.web2.http.HTTPError:
<twisted.web2.http.Response code=403,streamlen=None>
~/iCal/Twisted/twisted/web2/dav/resource.py:702:authenticate
~/iCal/Twisted/twisted/web2/dav/resource.py:1245:principalsForAuthID
~/iCal/Twisted/twisted/internet/defer.py:191:addCallback
~/iCal/Twisted/twisted/internet/defer.py:182:addCallbacks
--- <exception caught here>---
~/iCal/Twisted/twisted/internet/defer.py:317:_runCallbacks
~/iCal/Twisted/twisted/web2/dav/resource.py:1232:gotAuthn]'

(I cleaned up that logmsg just a bit - removed my absolute pathname and 
reformatted the single line to multiple lines - otherwise it's as the 
server reports.)


Any help much appreciated!

thanks

- Tim


More information about the calendarserver-dev mailing list