[CalendarServer-users] Lost newbie: Can't access via IP address although localhost works

Steven Chan bookondesk at gmail.com
Mon Nov 19 23:59:26 PST 2007

Hi, Emil,

Thanks very much!  That worked like a charm.  As you suspected, this  
is for my 8-node home network so I don't have a DNS (and therefore no  

After much messing about, I've rolled this into production, much to  
the delight of my wife.  Aside from this initial hurdle and some head- 
scratching over the accounts.xml structure, I can't believe how easy  
this was to set up...  at least for a reasonably technical user.

I've gotten sufficient hints in the archives of this listserv to think  
that setting this up as a launchd service won't be too hard.  Famous  
last words. ;-)

Hats off to the DCS team!


On Nov 19, 2007, at 4:22 AM, Emil Lundberg wrote:

Hi Steven,

No particular need for UNIX magic, although editing caldad-dev.plist  
is necessary. The default setup is to listen on the localhost  
interface only. Change the following elements in conf/caldavd-dev.plist:

   <!-- Network host name -->

   <!-- List of IP addresses to bind to [empty = all] -->


   <!-- Network host name -->

   <!-- List of IP addresses to bind to [empty = all] -->

Now, I suspect you might not have DNS running in your local setup? In  
this case, try leaving ServerHostName set to localhost,,  
or yourhostname.local (Bonjour name). For any production use though,  
you really want to have DNS running, using a FQDN...

For good measure, restart the daemon afterwards (e.g. ./run -rd). If  
things still fail, check logs/error.log for clues.



19 nov 2007 kl. 01.24 skrev Steven Chan:

> Hi, folks,
> Newbie warning:  you may need to speak slooowly to be understood, as  
> my UNIX skills are still nascent... ;-)
> I've installed Calendar Server from today's trunk on Leopard desktop  
> client 10.5.1 (not OS X Server).  It compiled fine and runs without  
> errors. I haven't altered the default caldavd-dev.plist.  My Leopard  
> client is connected to a D-Link 624 via DHCP, where it's been given  
> an IP of
> What works:
> --------------
> I can connect to it via iCal 3.0.1 (1205) using admin/admin against http://localhost:8008 
> .  I've been able to create a couple of new CalDAV calendars using  
> my local iCal client and the admin/admin account.
> I can also connect via Firefox 2.x against http://localhost:8008 and https://localhost:8443 
> .
> So far so good.  Substituting for in both test cases work  
> as expected, too.
> What doesn't work:
> ----------------------
> My local network IP address is
> I cannot access the Calendar Server via   
> I can ping this address using Network Utility running locally as  
> well as from other Macs.
> This fails locally in Firefox with the following error:  "Firefox  
> can't establish a connection to the server at"
> This fails locally in iCal with the following error:  "Account  
> information not found.  Connection to the server was  
> refused."
> Can anyone shed some light on why requests to localhost work but  
> requests to my explicit IP fail?
> Regards,
> Steven
> _______________________________________________
> calendarserver-users mailing list
> calendarserver-users at lists.macosforge.org
> http://lists.macosforge.org/mailman/listinfo/calendarserver-users

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.macosforge.org/pipermail/calendarserver-users/attachments/20071119/386e1d3c/attachment.html

More information about the calendarserver-users mailing list