[CalendarServer-users] Invalid argument

Jason Pruim japruim at raoset.com
Mon Apr 7 10:47:45 PDT 2008

On Apr 7, 2008, at 12:26 PM, Cyrus Daboo wrote:
> Hi Jason,
> --On April 7, 2008 12:19:08 PM -0400 Jason Pruim  
> <japruim at raoset.com> wrote:
>>>> Couldn't listen on any:logs/caldavd.sock: (22, 'Invalid argument').
>>> Do you have an existing logs/caldavd.sock file in place? If so,
>>> delete that.
>> Hi Cyrus,
>> I did that and just to be safe I also delete logs/caldavd.pid
> OK, could be a permissions problem then. Verify the file permissions  
> on logs and check what user you are running the server as (maybe try  
> sudo first).

Tried it with: sudo ./run and had the same error, then just to make  
sure I "sued" over to root (Since i have the access) and tried: ./run  
with the same result,

I looked at the permissions from workgroup manager ( I don't know much  
about checking permissions from the commandline) and it was listed as  
owner: japruim group: admin with read/write privileges to all the  

Any other ideas?


Jason Pruim
Raoset Inc.
Technology Manager
MQC Specialist
3251 132nd ave
Holland, MI, 49424-9337
japruim at raoset.com

More information about the calendarserver-users mailing list