[CalendarServer-users] debian, getting started

Frank Hartmann soundart at gmx.net
Sun Nov 16 07:47:54 PST 2008


I have some problems using calendarserver. I thought of having a
common appointment handling for 4 users and installed calendarserver.

Unfortunately my setup is acting as a complex /dev/zero device and I
am running against lots of walls trying to debug my setup.

I am running debian/testing, using the prepackaged version

I am a bit confused by the README.debian documentation, so followed
the guideline there verbatim and created two files on my system:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<!-- Sudo user definitions -->
<!-- With the exception of username and password none of the following
     elements are used in the current implementation. -->

<?xml version="1.0" encoding="utf-8"?>

<!DOCTYPE accounts SYSTEM "accounts.dtd">

<accounts realm="Test Realm">
    <name>Super User</name>
    <cuaddr>mailto:testuser at example.com</cuaddr>
    <name>Users Group</name>
      <member type="users">test</member>
    <name>Mecury Conference Room, Building 1, 2nd Floor</name>
      <member type="users">test</member>

There does not seem to be any description anywhere what role the
superuser from sudoers.plist or admin from accounts.xml have.

I have restarted the server and two logfiles were created:

Log opened - server start: [Sun Nov 16 16:02:20 2008]. - - [16/Nov/2008:16:05:58 +0200] "PROPFIND /calendars/users/test_user/calendar/ HTTP/1.1" 404 151 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20080916 Debian/unstable (Codename:      sid) Iceowl/0.8" [43.9 ms] - - [16/Nov/2008:16:06:13 +0200] "PUT /calendars/users/test_user/calendar/b152a194-62a0-48bc-96f1-30d6b65615a5.ics HTTP/1.1" 404 191 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20080916 Debian/unstable (Codename:
   sid) Iceowl/0.8" [27.3 ms] - - [16/Nov/2008:16:20:23 +0200] "PROPFIND /calendars/users/Test_user/calendar/ HTTP/1.1" 404 151 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20080916 Debian/unstable (Codename:      sid) Iceowl/0.8" [22.6 ms] - - [16/Nov/2008:16:20:39 +0200] "PUT /calendars/users/Test_user/calendar/4a361f89-67f8-4856-bb45-b88c3c293e0d.ics HTTP/1.1" 404 191 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20080916 Debian/unstable (Codename:
   sid) Iceowl/0.8" [81.9 ms]


2008-11-16 16:02:20+0100 [-] Log opened.
2008-11-16 16:02:20+0100 [-] twistd 8.1.0 (/usr/bin/python 2.5.2) starting up
2008-11-16 16:02:20+0100 [-] reactor class: <class 'twisted.internet.selectreactor.SelectReactor'>
2008-11-16 16:02:20+0100 [-] twistedcaldav.logging.AMPLoggingFactory starting on "'/var/run/caldavd/caldavd.socket'"
2008-11-16 16:02:20+0100 [-] [caldav-8008] /usr/lib/python2.5/site-packages/twisted/plugins/twisted_web2.py:22: DeprecationWarning: mktap and related support modules are deprecated as of Twisted 8.0.  Use Twisted Application Plugins with the 'twistd' command directly, as described in 'Writing a Twisted Application Plugin for twistd' chapter of the Developer Guide.
2008-11-16 16:02:20+0100 [-] [caldav-8008]   from twisted.scripts.mktap import _tapHelper
2008-11-16 16:02:21+0100 [-] [caldav-8008]  [-] Log opened.
2008-11-16 16:02:21+0100 [-] [caldav-8008]  [-] twistd 8.1.0 (/usr/bin/python 2.5.2) starting up
2008-11-16 16:02:21+0100 [-] [caldav-8008]  [-] reactor class: <class 'twisted.internet.selectreactor.SelectReactor'>
2008-11-16 16:02:21+0100 [-] [caldav-8008]  [-] twisted.web2.channel.http.HTTPFactory starting on 8008
2008-11-16 16:02:21+0100 [-] [caldav-8008]  [-] Starting factory <twisted.web2.channel.http.HTTPFactory instance at 0x898380c>
2008-11-16 16:02:21+0100 [-] [caldav-8008]  [-] set uid/gid 135/144
2008-11-16 16:02:21+0100 [twistedcaldav.logging.AMPLoggingFactory] AMPLoggingProtocol connection established (HOST:UNIXSocket('/var/run/caldavd/caldavd.socket') PEER:UNIXSocket(''))
2008-11-16 16:02:21+0100 [-] [caldav-8008]  [-] AMP connection established (HOST:UNIXSocket(None) PEER:UNIXSocket('/var/run/caldavd/caldavd.socket'))
2008-11-16 16:05:58+0100 [-] [caldav-8008]  [HTTPChannel,0,] Provisioning file: <CalendarHomeProvisioningFile: /var/spool/caldavd/calendars>
2008-11-16 16:05:58+0100 [-] [caldav-8008]  [HTTPChannel,0,] Provisioning file: <CalendarHomeTypeProvisioningFile: /var/spool/caldavd/calendars/users>
2008-11-16 16:05:58+0100 [-] [caldav-8008]  [HTTPChannel,0,] Provisioning file: <CalendarHomeTypeProvisioningFile: /var/spool/caldavd/calendars/users>

The entried from access.log is the result from using iceowl (debian
name for sunbird) creating a nerw calendar and trying to make an
entry. The location I specified there was  


and I tried


too. No password dialog appeared, no error messages. I added an
appointment into my new calendar and it vanishes without any error

I was not sure which side (server or client) was defective, so I
searched this mailing list for some sort of known good command line
client. I found:


and tried then CalDAVClientLibrary revision 3384:

fantasio:~/tmp/CalDAVClientLibrary$  ./runshell.py --server http://localhost:8008 --user=Test_user --pswd=test
Ignoring error
Ignoring error
Traceback (most recent call last):
  File "./runshell.py", line 32, in <module>
  File "/mnt/hdd2/home/frank/tmp.nobackup/CalDAVClientLibrary/src/browser/shell.py", line 105, in runit
    shell = Shell(server, user, pswd, logging)
  File "/mnt/hdd2/home/frank/tmp.nobackup/CalDAVClientLibrary/src/browser/shell.py", line 43, in __init__
    self.account = CalDAVAccount(server, ssl=ssl, user=self.user, pswd=self.pswd, root=paths, principal=paths, logging=logging)
  File "/mnt/hdd2/home/frank/tmp.nobackup/CalDAVClientLibrary/src/client/account.py", line 24, in __init__
    self.principal = principalCache.getPrincipal(self.session, self.session.principalPath)
  File "/mnt/hdd2/home/frank/tmp.nobackup/CalDAVClientLibrary/src/client/principal.py", line 35, in getPrincipal
    self.cache[principal.principalURL.toString()] = principal
AttributeError: 'str' object has no attribute 'toString'

At this point I decided to ask the mailing list. How do I debug this
further? Any documents I should have found?

kind regards

More information about the calendarserver-users mailing list