[CalendarServer-users] CalendarServer on Ubuntu 8.04

Georg Troska georg.troska at uni-dortmund.de
Sun Nov 16 10:28:02 PST 2008


I'm really interested in setting up a CalendarServer for my working  
group. So I just set up a new virtual machine with ubuntu 8.04 and  
tried to start. Unfortunately I get messaged like this after running  

2008-11-16 17:15:20-0100 [-] [memcached] memcached: error while  
loading shared libraries: libevent-1.4.so.2: cannot open shared object  
file: No such file or directory
2008-11-16 17:15:26-0100 [-] [caldav-8008]  [-] Starting factory  
<twistedcaldav.memcachepool.MemCacheClientFactory object at 0x1a5ae90>
2008-11-16 17:15:26-0100 [-] [caldav-8008]  [Uninitialized]  
[twistedcaldav.memcachepool.MemCacheClientFactory#error] MemCache  
connection failed: [Failure instance: Traceback (failure with no  
frames): <class 'twisted.internet.error.ConnectionRefusedError'>:  
Connection was refused by other side: 111: Connection refused.
2008-11-16 17:15:26-0100 [-] [caldav-8008]      ]
2008-11-16 17:15:26-0100 [-] [caldav-8008]  [Uninitialized]  
<twisted.internet.tcp.Connector instance at 0x1afba70> will retry in  
22 seconds
2008-11-16 17:15:26-0100 [-] [caldav-8008]  [Uninitialized] Stopping  
factory <twistedcaldav.memcachepool.MemCacheClientFactory object at  

I'm really sure that the file libevent-1.4.so.2 does exist and I tried  
to compile memcached on my own and it did.

Seems that the the path for the dynamic library is not set correctly  
somewhere ..? I hope you can help

Georg Troska
Experimentelle Physik IV
TU Dortmund
+49 231 755 3501

More information about the calendarserver-users mailing list