[CalendarServer-users] Almost running CalServer on Centos 5.4

Peter Huetmannsberger huetmann at violine.at
Mon Feb 1 15:16:17 PST 2010

Indeed I have, I followed those instructions, in the hope it would work. A 
number of things are different though, which may have to do with a newer 
version delivered by the CVS. It wants to have postgres installed now. 
Which I did.

The whole thing seems to place files all over the place and then can't 
find them.

I have to start the command
/usr/bin/caldavd -X -f /etc/caldavd/caldavd.plist

in the directory I built the CalendarServer otherwise it won't start.

I may have missed something, but I tried 6 times from scratch with a new 
virtual machine (i.e. clean setup). Always ended up with the same thing. I 
can't log on.

Today I tried it on Ubuntu, which installs an older version, and even 
though there was some problem with the packaging, it worked pretty much 
out of the box (using the deb package). However Ubuntu is not an option 
for me, I have to get this to run on a centos install.

If you would like to see some logs, I could mail/post  them.

I also tried everything on a fedora virtual machine today, and I get to 
the pount where Sunbird can connect and make events, but my Iphone 
cannot. (weird thing is that it works on the ubuntu install, with the 
exact same settings).

In Fedora, it seems that the account is recognized. (I can log on) but I 
cannot go to any ressources (including my own calendar) it returns, a 500 
(Internal Server Error).

2010-02-02 00:13:36+0100 [-] [caldav-2]           File 
"/usr/lib64/python2.6/site-packages/twisted/enterprise/adbapi.py", line 
395, in connect
2010-02-02 00:13:36+0100 [-] [caldav-2]             conn = 
self.dbapi.connect(*self.connargs, **self.connkw)
2010-02-02 00:13:36+0100 [-] [caldav-2]         sqlite3.OperationalError: 
unable to open database file

The above is what the log says.

Sorry my python is non-existent.

So, it seems I am stuck. But thanks anyway.

If you can help, that would be wonderful.



On Mon, 1 Feb 2010, Guy wrote:

> have you reviewed this documentation?
> http://www.rho.cc/index.php/linux2/48-misc/48-installing-darwin-calendar-server-on-centos-5
> Cheers,
> ---Guy
> On Feb 01, 2010, at 20:51, huetmann wrote:
>> Hi,
>> after following the instructions in various websites for DCS and Centos, I
>> got fairly far, but not quite there.
>> I have the server up and running, it gives me a listing of sorts,when I
>> approach it with Firefox 3.0, but it does not let me log on as anyone. As
>> soon as I type the authentication superuser/superuser it gives me an error
>> "400 Bad Request". All the other standard users in account.xml don't work at
>> all (Auth window comes back).
>> Is there a simple caldavd.plist I could use for authentication. I thought
>> that this would have to work at least:
>> <key>Authentication</key>
>>    <dict>
>>      <!-- Clear text; best avoided -->
>>      <key>Basic</key>
>>      <dict>
>>        <key>Enabled</key>
>>        <true/>
>>      </dict>
>> But no luck. (The accounts.xml is where it is supposed to be. )
>> I also have a problem with memcached, i.e.:
>> [memcached-Default] can't run as root without the -u switch
>> Maybe those two problems are connected. But I am at the end of my tether
>> here, haveing spent more than 12 hours trying to get this to run.
>> Any help is appreciated. Maybe it is something small I am missing!
>> Thanks
>> Peter
>> --
>> View this message in context: http://old.nabble.com/Almost-running-CalServer-on-Centos-5.4-tp27396140p27396140.html
>> Sent from the Calendar Server - Users mailing list archive at Nabble.com.
>> _______________________________________________
>> calendarserver-users mailing list
>> calendarserver-users at lists.macosforge.org
>> http://lists.macosforge.org/mailman/listinfo.cgi/calendarserver-users


Please note that my email has changed to:
huetmann at violine.at

More information about the calendarserver-users mailing list