[CalendarServer-users] Installing Calendar Server

Mike Greiner mgreiner at me.com
Sun Nov 14 10:10:18 PST 2010


Hi Godfrey,

I can share a few tips. I just started working with the calendar server this week and I encountered some of the same problems.

Note: I'm new to this list, so for those with more experience --- please speak up if I'm giving bad advice :)

> unrecognized .svn/entries format in 
> conftest.c:1:23: error: sys/epoll.h: No such file or directory
> conftest.c:1:23: error: sys/epoll.h: No such file or directory
> conftest.c:1:23: error: sys/epoll.h: No such file or directory
> lipo: can't open input file: /var/folders/NF/NF7P443VE3K04yAADfdxwE+++TI/-Tmp-//ccGWCmnv.out (No such file or directory)
> 
> 

I saw this error as well, but I didn't follow up on it. Like you said, it doesn't appear to cause any problems.


> Except, when I perform the pax command as an admin, not root, it has permission errors. So I installed as root and tried to run as admin user and items such as ./data were missing (need to run as non-root for PosrGRESQL reasons) eg

I can't exactly recall, but I think I needed to run pax as root as well. However, you can (and should) run caldavd as a regular user. You can do that by specifying a user and group in the caldavd.plist file.

> twistedcaldav.config.ConfigurationError: Server root does not exist: ./data
> 
> So, how is the data directory supposed to be created? How is one supposed to install/deploy?

The problem here is with your caldavd.plist. If you copied the caldavd-test.plist to caldavd-dev.plist (like the run script recommends), then the server's root folder is specified as a relative path:
    <key>ServerRoot</key>
    <string>./data</string>

This works fine if you're running caldavd from the source tree, but not in deployment. I used an absolute path in my plist:
    <key>ServerRoot</key>
    <string>/Library/CalendarServer/Data</string>

> 
> 3) Tried to start caldavd from within my test area but got some sort of index out of range error:

<snip>
> 
> 2010-11-14 13:21:20+1100 [-]   File "/CalendarServer/txdav/base/datastore/subpostgres.py", line 382, in startService
> 2010-11-14 13:21:20+1100 [-]     initdb = which("initdb")[0]
> 2010-11-14 13:21:20+1100 [-] IndexError: list index out of range
</snip>

The problem here is that your server can't find PostgreSQL. It appears that executing "./run -i" does not deploy PostgreSQL. You can install it from the PostgresSQL source yourself. Check out the instructions in the file postgresql-9.0.1/INSTALL

The only problem I had after that was that my PATH didn't include the location where I installed PostgreSQL (/usr/local/pgsql). Since I'm running the server as a launch daemon using launchd, I expected that having a setenv command in my launchd.config file would work -- but it didn't. Then I tried putting an entry in /etc/paths.d, but that didn't work either. Eventually I gave up and just added the path to my deployed copy of my caldavd shell script at /usr/local/bin/caldavd.  :(

Anyway, that was enough to get things running for me in my test environment. My next challenge is to get this running on my creaky old 10.4 server.

Hope that helps,
Mike


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macosforge.org/pipermail/calendarserver-users/attachments/20101114/991a62a5/attachment.html>


More information about the calendarserver-users mailing list