[CalendarServer-users] Running CalendarServer on Mac OS X 10.8.5

Andre LaBranche dre at apple.com
Thu Nov 7 15:15:56 PST 2013


It does indeed appear that run -i is still broken.

Even so, it's fine to just run the service in place, using the run script. Normally doing something like this would be a mess of fixing up environment variables and adding things to various paths, but our run script does this for you, no matter where you execute it from. I might recommend creating another user account to run the service, to isolate it from your own personal login session. It doesn't need to run as root.

For example:

andre at xomg[~] /Users/andre/work/icalserver/trunk/CalendarServer/run -n 
Using system version of memcached.

Using system version of OpenLDAP.

Using system version of libffi.

Using system version of setuptools.

Unable to determine version for zope.interface.
Using system version of pyOpenSSL.

Using system version of xattr.

Using system version of Twisted.

Using system version of python-dateutil.

Using system version of pytz.

Using python2.7 as Python

Starting server...
Reading configuration from file: /Volumes/xomg/Users/andre/work/icalserver/trunk/CalendarServer/conf/caldavd-dev.plist
2013-11-07 14:56:41-0800 [-] Log opened.
2013-11-07 14:56:41-0800 [-] [twisted.application.app#info] twistd 12.2.0 (/System/Library/Frameworks/Python.framework/Versions/2.7/Resources/Python.app/Contents/MacOS/Python 2.7.5) starting up.

You can integrate this with launchd as well; just make sure to not pass the -d option with run. One side effect of using run without -d is that no separate error.log is written; instead all that content goes to stdout. To get a separate error.log file, define StandardOutPath and StandardErrorPath in your launchd plist, with the desired path to the log file.


On Nov 7, 2013, at 12:55 PM, Bernhard Spinnler <Bernhard.Spinnler at gmx.net> wrote:

> Just noticed that this issue has been reported already 17 months ago: http://trac.calendarserver.org/ticket/485?cversion=1&cnum_hist=5 and seems to be still open.
> Does anyone know about progress on this issue? Is anyone able to install the server via './run -i'?
> Thanks,
> 	Bernhard
> On 06.11.2013, at 22:16, Bernhard Spinnler <Bernhard.Spinnler at gmx.net> wrote:
>> All,
>> I am trying to run CalendarServer on a MBP running OS X 10.8.5. I am using release CalendarServer 5.0. Setting up the server with the command './run -s' seems to work mostly well. Only one question here: During compilation of Twisted I get a compiler error:
>> clang -fno-strict-aliasing -fno-common -dynamic -g -Os -pipe -fno-common -fno-strict-aliasing -fwrapv -mno-fused-madd -DENABLE_DTRACE -DMACOSX -DNDEBUG -Wall -Wstrict-prototypes -Wshorten-64-to-32 -DNDEBUG -g -Os -Wall -Wstrict-prototypes -DENABLE_DTRACE -arch i386 -arch x86_64 -I/Users/Admin/Tmp/calendar/postgresql-9.1.2/_root/include -pipe -I/System/Library/Frameworks/Python.framework/Versions/2.7/include/python2.7 -c conftest.c -o conftest.o
>> clang: warning: argument unused during compilation: '-mno-fused-madd'
>> conftest.c:1:10: fatal error: 'sys/epoll.h' file not found
>> #include <sys/epoll.h>
>>        ^
>> 1 error generated.
>> However, the setup process seems to proceed normally and I can run the server using './run'. I can add the server in AddressBook and Calendar, add contacts and so on. Everything seems to work. Any ideas what the error is about? Is it serious?
>> Then I tried to install the server properly with './run -i /Users/username/Tmp' as it is suggested in 'run'. I get the same error during Twisted compile (which I ignore). However, installing CalDAVClientLibrary fails after lots of copying and byte-compiling with error
>> running install_data
>> creating /Users/Admin/Tmp/cs/System
>> creating /Users/Admin/Tmp/cs/System/Library
>> creating /Users/Admin/Tmp/cs/System/Library/Frameworks
>> creating /Users/Admin/Tmp/cs/System/Library/Frameworks/Python.framework
>> creating /Users/Admin/Tmp/cs/System/Library/Frameworks/Python.framework/Versions
>> creating /Users/username/Tmp/cs/System/Library/Frameworks/Python.framework/Versions/2.7
>> warning: install_data: setup script did not provide a directory for 'caldavclientlibrary/ui/WebDAVBrowser.nib' -- installing right in '/Users/username/Tmp/cs/System/Library/Frameworks/Python.framework/Versions/2.7'
>> error: can't copy 'caldavclientlibrary/ui/WebDAVBrowser.nib': doesn't exist or not a regular file
>> I checked the file 'caldavclientlibrary/ui/WebDAVBrowser.nib' and sure enough it's a bundle, i.e. in Unix terms a directory, not a regular file. Any ideas why I get this error? Could I have wrong tools installed? I have XCode 5.0.1.
>> TIA,
>> 	Bernhard
>> _______________________________________________
>> calendarserver-users mailing list
>> calendarserver-users at lists.macosforge.org
>> https://lists.macosforge.org/mailman/listinfo/calendarserver-users
> _______________________________________________
> calendarserver-users mailing list
> calendarserver-users at lists.macosforge.org
> https://lists.macosforge.org/mailman/listinfo/calendarserver-users

More information about the calendarserver-users mailing list