[CalendarServer-users] SSL Ciphers

m at ainc.be
Tue Mar 11 14:04:07 PDT 2014

Thank you for the reply, very much appreciated. The issue is fixed 
(after changing SSLAuthorityChain as suggested).

Many thanks,

------ Original Message ------
From: "R.Sv." <rsv at balsec.com>
To: calendarserver-users at lists.macosforge.org
Sent: 11/03/2014 4:02:29 AM
Subject: Re: [CalendarServer-users] SSL Ciphers

>On 10.03.2014 00:23, m at ainc.be wrote:
>>I've setup the latest version of CalendarServer on Wheezy and 
>>everything works fine with the exception of SSL functionality. The 
>>public, private and CA cert files are configured as described in the 
>>default configuration and they are accessible by CalendarServer. 
>>Nothing can connect to the SSL port, and neither the access or error 
>>logs show anything. Phython2.7 is listening on the SSL port. The only 
>>thing I could get was from Firefox giving the error: (Error code: 
>>ssl_error_no_cypher_overlap). I tried setting the SSLChiphers key to 
>>ALL in caldavd.plist but nothing happened.
>>calendarserver-users mailing list
>>calendarserver-users at lists.macosforge.org
>Hi m at ainc.be
>we had also problems with SSL and calendarserver 3 under Wheezy. It all 
>was solved when we added the server certificate also the the chain 
>  - SSLCertificate => single server cert
>  - SSLAuthorityChain => server cert, issuing/intermediate cert(s), root 
>cert (with "cat >> chain-file")
>Give it a try, our SSL works fine now, without any cipher settings
>best regards, Radim
>calendarserver-users mailing list
>calendarserver-users at lists.macosforge.org

More information about the calendarserver-users mailing list