[CalendarServer-users] Trouble upgrading from 5.3 to 7.0

Jacques Distler distler at golem.ph.utexas.edu
Mon Jan 25 07:43:00 PST 2016

> On Jan 25, 2016, at 8:57 AM, Cyrus Daboo <cdaboo at apple.com> wrote:
> -t Slave is not meant for normal operation.

I realize that. But it has the advantage of skipping the database checks and (apparently) succeeds in binding to Port 8443. Neither of the other two modes get that far.

> I wonder if you have a permissions issue. Have you tried running it via sudo?

I've tried both 'sudo' and running directly as root ( via 'su'). The result is the same.

The other difference, which I should have noted, is that "-t Slave" successfully drops privileges (so that "lsof -i" lists the processes as running under the user _calendar), whereas "-t Combined" and "-t Single" are still shown as running as root.

> Have you tried installing directly from our latest svn trunk into a separate directory with a clean DB?

Haven't tried that yet.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 203 bytes
Desc: Message signed with OpenPGP using GPGMail
URL: <https://lists.macosforge.org/pipermail/calendarserver-users/attachments/20160125/f358bf11/attachment.sig>

More information about the calendarserver-users mailing list