[CalendarServer-users] Error on bin/develop

Rob Archibald rob at robarchibald.com
Fri Feb 17 17:16:09 PST 2017


I've already submitted 2 pull requests for fixes to make Calendar Server
work better on Ubuntu. I've got a long message on Github that describes a
lot of what I've discovered so far
https://github.com/apple/ccs-calendarserver/pull/473. I'm determined to get
Calendar Server running like a champ on Ubuntu.


So far, I'm not running into any incompatibilities or other big issues, just
documentation problems or minor differences between environments that can be
solved with a few lines of changes here and there. The Calendar Server team
has been open to my help so far so it's been great. I'm testing all my
changes over and over using a pristine Ubuntu 16.04 image so once I get it
working it should be drop-dead simple for anyone else to get it running on
Ubuntu and likely any other Debian variant. 




From: Jeff Kletsky [mailto:caldav at allycomm.com] 
Sent: Friday, February 17, 2017 4:53 PM
To: Rob Archibald; calendarserver-users at lists.macosforge.org
Subject: Re: [CalendarServer-users] Error on bin/develop


Thanks Rob!

I had put CalendarServer on Ubuntu on my back burner for seeing the same
errors you reported.

Definitely appreciate the insight!




On 2/17/17 4:50 PM, Rob Archibald wrote:

Nevermind. After tracking it down deep enough to be able to ask the
question, the answer wasn't far away. Turns out that after a bit more
digging, I found that my system didn't have ldap.h available. After a simple
apt-get install libldap2-dev, it finished with no errors.


From: Rob Archibald [mailto:rob at robarchibald.com] 
Sent: Friday, February 17, 2017 4:38 PM
To: 'calendarserver-users at lists.macosforge.org'
Subject: Error on bin/develop


I'm running Calendar Server 9.0 on Ubuntu 16.04.1. It seems to be working
fine, but I have this nagging error in the back of my mind that makes me
worry that something still isn't quite right. When I run bin/develop, I
receive the following error: 


.../ccs-calendarserver-CalendarServer-9.0/bin/_py.sh: line 104: [: # 1
"<stdin>": integer expression expected

.../ccs-calendarserver-CalendarServer-9.0/bin/_py.sh: line 109: [: # 1
"<stdin>": integer expression expected


It works even though I receive this error, so I'm trying to understand it to
see if it matters. This is in the middle of a function called cmp_version
which is expecting numeric arguments. It receives these 2 values:


1.       20428 - seems OK

2.       # 1 "<stdin>" - looks bad to me


It looks like the c_macro function is the source of the bad 2nd value. From
what I can tell, the function is being called on ldap.h and trying to get
LDAP_VENDOR_VERSION, but instead gets back the bogus value.  I'm guessing
this means LDAP won't work for me?




Rob Archibald, M.M.

CTO, EndFirst LLC

Founder and Music Director, Ensign Symphony & Chorus

rob at robarchibald.com


calendarserver-users mailing list
calendarserver-users at lists.macosforge.org


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.macosforge.org/pipermail/calendarserver-users/attachments/20170217/cd920f2d/attachment.html>

More information about the calendarserver-users mailing list