<html><head></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; ">Here is some console logs (client side).<div><br></div><div><div>2/11/10 16:25:18 <span class="Apple-tab-span" style="white-space:pre">        </span>iCal[43637]<span class="Apple-tab-span" style="white-space:pre">        </span>CalDAV CalDAVAccountRefreshQueueableOperation failed: status 'HTTP/1.1 404 Not Found' request:</div><div><br></div><div>&lt;?xml version="1.0" encoding="utf-8"?&gt;</div><div>&lt;x0:propfind xmlns:x1="urn:ietf:params:xml:ns:caldav" xmlns:x0="DAV:" xmlns:x2="<a href="http://calendarserver.org/ns/">http://calendarserver.org/ns/</a>"&gt;</div><div>&nbsp;&lt;x0:prop&gt;</div><div>&nbsp;&nbsp;&lt;x0:principal-collection-set/&gt;</div><div>&nbsp;&nbsp;&lt;x1:calendar-home-set/&gt;</div><div>&nbsp;&nbsp;&lt;x1:calendar-user-address-set/&gt;</div><div>&nbsp;&nbsp;&lt;x1:schedule-inbox-URL/&gt;</div><div>&nbsp;&nbsp;&lt;x1:schedule-outbox-URL/&gt;</div><div>&nbsp;&nbsp;&lt;x2:dropbox-home-URL/&gt;</div><div>&nbsp;&nbsp;&lt;x2:xmpp-uri/&gt;</div><div>&nbsp;&nbsp;&lt;x2:notification-URL/&gt;</div><div>&nbsp;&nbsp;&lt;x0:displayname/&gt;</div><div>&nbsp;&nbsp;&lt;x0:principal-URL/&gt;</div><div>&nbsp;&nbsp;&lt;x0:supported-report-set/&gt;</div><div>&nbsp;&lt;/x0:prop&gt;</div><div>&lt;/x0:propfind&gt;</div><div><br></div><div>... response:</div><div>HTTP/1.1 404 Not Found</div><div>Date: Tue, 02 Nov 2010 15:25:18 GMT</div><div>Content-Length: 173</div><div>Content-Type: text/html;charset=utf-8</div><div>Server: Twisted/8.2.0 TwistedWeb/8.2.0</div><div><br></div><div>&lt;html&gt;&lt;head&gt;&lt;title&gt;404 Not Found&lt;/title&gt;&lt;/head&gt;&lt;body&gt;&lt;h1&gt;Not Found&lt;/h1&gt;The resource /principals/__uids__/{userid}/ cannot be found.&lt;/body&gt;&lt;/html&gt;</div><div>2/11/10 16:25:19 <span class="Apple-tab-span" style="white-space:pre">        </span>iCal[43637]<span class="Apple-tab-span" style="white-space:pre">        </span>CalDAV CalDAVRefreshDelegateListQueueableOperation failed: status 'HTTP/1.1 404 Not Found' request:</div><div><br></div><div>&lt;?xml version="1.0" encoding="utf-8" ?&gt;</div><div>&lt;x0:expand-property xmlns:x0="DAV:"&gt;&lt;x0:property name="calendar-proxy-write-for" namespace="<a href="http://calendarserver.org/ns/">http://calendarserver.org/ns/</a>"&gt;&lt;x0:property name="displayname"/&gt;&lt;x0:property name="principal-URL"/&gt;&lt;x0:property name="calendar-user-address-set" namespace="urn:ietf:params:xml:ns:caldav"/&gt;&lt;/x0:property&gt;&lt;x0:property name="calendar-proxy-read-for" namespace="<a href="http://calendarserver.org/ns/">http://calendarserver.org/ns/</a>"&gt;&lt;x0:property name="displayname"/&gt;&lt;x0:property name="principal-URL"/&gt;&lt;x0:property name="calendar-user-address-set" namespace="urn:ietf:params:xml:ns:caldav"/&gt;&lt;/x0:property&gt;&lt;/x0:expand-property&gt;</div><div><br></div><div>... response:</div><div>HTTP/1.1 404 Not Found</div><div>Date: Tue, 02 Nov 2010 15:25:19 GMT</div><div>Content-Length: 173</div><div>Content-Type: text/html;charset=utf-8</div><div>Server: Twisted/8.2.0 TwistedWeb/8.2.0</div><div><br></div><div>&lt;html&gt;&lt;head&gt;&lt;title&gt;404 Not Found&lt;/title&gt;&lt;/head&gt;&lt;body&gt;&lt;h1&gt;Not Found&lt;/h1&gt;The resource /principals/__uids__/{userid}/ cannot be found.&lt;/body&gt;&lt;/html&gt;</div><div>2/11/10 16:25:20 <span class="Apple-tab-span" style="white-space:pre">        </span>iCal[43637]<span class="Apple-tab-span" style="white-space:pre">        </span>Unhandled error: [CalDAVQueueableOperation finishOperation] _error = Error Domain=DAVErrorDomain Code=10 UserInfo=0x1152a4ad0 "The operation couldn’t be completed. (DAVErrorDomain error 10.)".</div><div><br></div><div><br><div>
<span class="Apple-style-span" style="font-family: Helvetica; "><div style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; "><br><b>Mvh&nbsp;<br>Christoffer Winterkvist<br></b><a href="mailto:christoffer@winterkvist.com">christoffer@winterkvist.com</a><br><a href="http://www.twitter.com/MrStench">http://www.twitter.com/MrStench</a><br><br><br><br></div></span>
</div>
<br><div><div>On 2, Nov,2010, at 16:20, Christoffer Winterkvist wrote:</div><br class="Apple-interchange-newline"><blockquote type="cite"><div style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; "><div>On 1, Nov,2010, at 17:46, Michael Ney wrote:</div><br class="Apple-interchange-newline"><blockquote type="cite"><div bgcolor="#ffffff" text="#000000">Christoffer,<br><br>Sorry that didn't work. I'm running essentially the same set up as you and not having the issue (though I have never been able to get the wiki calendars working in the wiki, but they do work with iCal).<br><br></div></blockquote><div><br></div><div>Everything works fine if I don't restart the service.</div><div>I'm no expert but I'm guessing something is a bit of in the "init" function for the calendar server.</div><div>I glanced at the change sets over at Calendar &amp; Contacts server but I could find any recent changes.</div><div><br></div><div>I'm having the same issue with my other server... but the exception is that that server is running</div><div>an OD and users inside the OD are not affected. Users in the stand alone directory still have</div><div>the exact same issue.</div><br><blockquote type="cite"><div bgcolor="#ffffff" text="#000000">Hopefully someone else has ideas. I know standalone OD works fine, since we use that.<br><br><br>On 11/1/10 12:34 PM, Christoffer Winterkvist wrote:<blockquote cite="mid:638C3EDF-0070-4DDD-BF9A-29C4EA96AE7E@winterkvist.com" type="cite"><div><div>On 1, Nov,2010, at 17:11, Michael Ney wrote:</div><br class="Apple-interchange-newline"><blockquote type="cite"><div bgcolor="#ffffff" text="#000000">Christoffer,<br><br>Based on your description, I think what you are experiencing is a bug in the Calendar Server that broke wiki calendars in OS 10.6.4 from an iCal client.</div></blockquote><div><br></div><div>Well, the only thing that works as it should after a restart is the Wiki calendar?</div><div>I find that quite odd.</div><br><blockquote type="cite"><div bgcolor="#ffffff" text="#000000">iCal client began properly addressing the server, exposing a long standing bug with the Calendar Server that was previously masked by the improper behavior of iCal client. This change fixes the issue on the server:<br><br><a moz-do-not-send="true" class="moz-txt-link-freetext" href="http://trac.calendarserver.org/changeset/5775/CalendarServer/branches">http://trac.calendarserver.org/changeset/5775/CalendarServer/branches</a><br><br>The file that needs changing on 10.6.4 server is at /usr/share/caldavd/lib/python/twistedcaldav/directory/principal.py<br><br></div></blockquote><div><br></div><div>When I edit the source it says exactly what the green change marker says so I'm already running</div><div>the latest changeset.</div><br><blockquote type="cite"><div bgcolor="#ffffff" text="#000000">Once you make the change, restart the iCal server from the Server Admin Tool. Check your console logs to make sure there are no errors.<br><br>Note: We do not yet know if OSX Server 10.6.5 will include this change or not (depends on if they update the iCal server to the latest version), so be aware you might have to make the fix again after updating to 10.6.5 once it comes out.<br></div></blockquote><div><br></div><div>Thats okay as long as I know what wrong with it.</div><div>But this did not seem to do the trick.</div><div><br></div><div>Here is a extract from one of my logfiles (pastebin url)</div><div><a moz-do-not-send="true" href="http://pastebin.com/Kp5X2q5Q">http://pastebin.com/Kp5X2q5Q</a></div><br><blockquote type="cite"><div bgcolor="#ffffff" text="#000000"><br>Michael<br><br><br>On 11/1/10 11:49 AM, Christoffer Winterkvist wrote:<blockquote cite="mid:1D5C866F-5D70-486A-928F-17F87FE3CD89@winterkvist.com" type="cite">So your saying the calendar server should not be working at all?<div>I'm running both Wiki calendars and normal calendars on the server without using a OD master?</div><div>Is this new requirement in 10.6.4, where is this stated?</div><div><div><span class="Apple-style-span" style="font-family: Helvetica; "></span><div style="word-wrap: break-word; font-family: Helvetica; "><br><b>Mvh&nbsp;<br>Christoffer Winterkvist<br></b><a moz-do-not-send="true" href="mailto:christoffer@winterkvist.com">christoffer@winterkvist.com</a><br><a moz-do-not-send="true" href="http://www.twitter.com/MrStench">http://www.twitter.com/MrStench</a><br><br><br><br></div><span class="Apple-style-span" style="font-family: Helvetica; "></span></div><br><div><div>On 1, Nov,2010, at 16:44, Morgen Sagen wrote:</div><br class="Apple-interchange-newline"><blockquote type="cite"><div>10.6.4 Calendar server requires users be in an OD master. &nbsp;<br><br>~morgen<br><br>On Nov 1, 2010, at 7:13 AM, JJ wrote:<br><br><blockquote type="cite">hi Christoffer,<br></blockquote><blockquote type="cite"><br></blockquote><blockquote type="cite">I had this exact problem at one site; all other installations were running fine. Tried all kinds of things to fix it, nothing worked, until I realized the way this one site differed from the others: it was the only Standalone directory.<br></blockquote><blockquote type="cite"><br></blockquote><blockquote type="cite">Converted it to Open Directory Master, and it's been running perfectly since then.<br></blockquote><blockquote type="cite"><br></blockquote><blockquote type="cite">(Just guessing here, but probably the Standalone config is used &amp; tested a lot less?)<br></blockquote><blockquote type="cite"><br></blockquote><blockquote type="cite">grtz, JJ Spreij<br></blockquote><blockquote type="cite"><br></blockquote><blockquote type="cite"><a moz-do-not-send="true" href="mailto:div.nabble@demon.cx">div.nabble@demon.cx</a><br></blockquote><blockquote type="cite"><br></blockquote><blockquote type="cite"><blockquote type="cite">I'm having some trouble with the iCal Server.<br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite">Everything works just as it should until I restart the server. When I do all iCal clients get prompted with:<br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite">The server responded with an error.<br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite">The calendar&nbsp;<a moz-do-not-send="true" href="https://serveraddress/principals/__uids__/%7Buid%7D/">https://serveraddress/principals/__uids__/{uid}/</a>&nbsp;was not found on the server. Make sure the URL is correct.<br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite">And it keeps prompting about that until iCal.app crashes or I remove the account.<br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite">When I add the account again in iCal everything seems to be working O.K... until I do another restart of the iCal server.<br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite">It seems that it is only the "normal" account that are affected... Wiki Calendars work as they are suppose to even after a restart.<br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite">I'm running a Mac OS X Server 10.6.4 with a Standalone directory.<br></blockquote></blockquote><blockquote type="cite"><br></blockquote><blockquote type="cite">_______________________________________________<br></blockquote><blockquote type="cite">calendarserver-users mailing list<br></blockquote><blockquote type="cite"><a moz-do-not-send="true" href="mailto:calendarserver-users@lists.macosforge.org">calendarserver-users@lists.macosforge.org</a><br></blockquote><blockquote type="cite"><a moz-do-not-send="true" href="http://lists.macosforge.org/mailman/listinfo.cgi/calendarserver-users">http://lists.macosforge.org/mailman/listinfo.cgi/calendarserver-users</a><br></blockquote><br>_______________________________________________<br>calendarserver-users mailing list<br><a moz-do-not-send="true" href="mailto:calendarserver-users@lists.macosforge.org">calendarserver-users@lists.macosforge.org</a><br><a moz-do-not-send="true" class="moz-txt-link-freetext" href="http://lists.macosforge.org/mailman/listinfo.cgi/calendarserver-users">http://lists.macosforge.org/mailman/listinfo.cgi/calendarserver-users</a><br></div></blockquote></div><br></div><pre wrap=""><fieldset class="mimeAttachmentHeader"></fieldset>
_______________________________________________
calendarserver-users mailing list
<a moz-do-not-send="true" class="moz-txt-link-abbreviated" href="mailto:calendarserver-users@lists.macosforge.org">calendarserver-users@lists.macosforge.org</a>
<a moz-do-not-send="true" class="moz-txt-link-freetext" href="http://lists.macosforge.org/mailman/listinfo.cgi/calendarserver-users">http://lists.macosforge.org/mailman/listinfo.cgi/calendarserver-users</a>
</pre></blockquote></div></blockquote></div><br></blockquote></div></blockquote></div>_______________________________________________<br>calendarserver-users mailing list<br><a href="mailto:calendarserver-users@lists.macosforge.org">calendarserver-users@lists.macosforge.org</a><br>http://lists.macosforge.org/mailman/listinfo.cgi/calendarserver-users<br></blockquote></div><br></div></div></body></html>