[darwinbuild] booting xnu 8G32

ritchie darwinbuild at repentsinner.org
Thu Feb 2 10:12:28 PST 2006

I managed to build xnu 8G32 quite easily last night, and am quite  
impressed with how slick darwinbuild is. however, when I go to  
install it on my system, I have the same problem that davec did a  
month ago: get to the grey apple boot screen and then wedge. am I  
missing any dependencies, or does the kernel need patching? is there  
anything tricky I need to do to handle a universal binary? I tried  
updating the kextcache for the kernel, and also tried booting the ppc  
only version but had no luck with either. I also updated the build  
plist to the 8g32od1 version, which doesn't seem to affect xnu from  
what I can tell. has anyone booted 8.4.1 yet?

I also looked into building the entire system via kevin's

# darwinxref version '*' | sed -e 's/-.*//' > projects.txt
# /usr/local/share/darwinbuild/buildorder projects.txt ordered.txt
# /usr/local/share/darwinbuild/buildlist ordered.txt

but this fails since I haven't fetched all the packages yet. is there  
a quick way to do the equivalent of darwinbuild -fetch *, or should I  
just hack a little curl script together? if I don't _need everything  
just to get a custom kernel up and running, I won't bother with this  


More information about the darwinbuild-dev mailing list