[darwinbuild-dev] xcodebuild errors out because it cannot find a valid Xcode project

William Siegrist wsiegrist at apple.com
Fri May 16 18:04:19 PDT 2008

On May 6, 2008, at 7:40 PM, William Siegrist wrote:

> On May 6, 2008, at 6:42 PM, Ryan Spaulding wrote:
>> Hi List,
>> I am getting an xcodebuild error when darwinbuild is trying to  
>> build IOKitUser because it cannot find the xcode project file. When  
>> am not chrooted I can run xcodebuild and it runs fine. I also  
>> chrooted by hand and tried and got the same error.
>> Any ideas, I am new to darwinbuild.
> You are hitting <http://darwinbuild.macosforge.org/trac/ticket/1>.
> I'm trying to find a workaround, but can't say when that'll happen.  
> If you're good with dtrace, you might try tracing the process and  
> see what the difference is between the two cases.  So far the  
> biggest difference is you get a lot of open*() calls for volfs when  
> it works, and none, if any, when its in a chroot and fails.

You can work around this by building on UFS for now. I'm still working  
on a permanent fix.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 2421 bytes
Desc: not available
Url : http://lists.macosforge.org/pipermail/darwinbuild-dev/attachments/20080516/577da36c/attachment.p7s 

More information about the darwinbuild-dev mailing list