[darwinbuild-dev] building tokend on 10.7, with 10J869 and Xcode 4.1

Nao Itoi nao.itoi at centrify.com
Tue May 31 12:22:38 PDT 2011


I am new to darwinbuild.
Thank you very much for your great work on this.

I am trying to build Tokend on MacOS 10.7 (Lion) Preview (build 11A459e) with Xcode 4.1 Preview (build 4B56d).
My purpose is to get tokend for MacOS 10.7.

I am using darwinbuild build 10J869, which is for 10.7 (thank you, Bill http://lists.macosforge.org/pipermail/darwinbuild-dev/2011-March/000649.html).

I followed the instructions on the web to:

1. build & install darwinbuild
2. Darwinbuild –init
3. Darwinbuild Tokend
4. Also tried darwinbuild SmartCardServices

Both 3 and 4 result in Xcode crash -

/Developer/usr/bin/xcodebuild install -sdk SRCROOT=/Users/nao/workp4/smartcardservices/10J869/BuildRoot/SourceCache/Tokend/Tokend-40596 OBJROOT=/Users/nao/workp4/smartcardservices/10J869/BuildRoot/private/var/tmp/Tokend/Tokend-40596.obj SYMROOT=/Users/nao/workp4/smartcardservices/10J869/BuildRoot/private/var/tmp/Tokend/Tokend-40596.sym DSTROOT=/Users/nao/workp4/smartcardservices/10J869/BuildRoot/private/var/tmp/Tokend/Tokend-40596.root RC_ProjectName=Tokend RC_ProjectSourceVersion=40596 RC_ProjectNameAndSourceVersion=Tokend-40596 RC_ProjectBuildVersion=1 INSTALLED_PRODUCT_ASIDES=YES MACOSX_DEPLOYMENT_TARGET=10.6 NEXT_ROOT= RC_ARCHS=i386 x86_64 RC_CFLAGS=-pipe -arch i386 -arch x86_64 RC_JASPER=YES RC_NONARCH_CFLAGS=-pipe RC_OS=macos RC_PRIVATE=/private RC_RELEASE=SnowLeopard RC_TARGET_CONFIG=MacOSX RC_XBS=YES RC_i386=YES RC_x86_64=YES SEPARATE_STRIP=YES UNAME_RELEASE=10.0 UNAME_SYSNAME=Darwin
** INTERNAL ERROR: Uncaught exception **
Exception: -[__NSCFDictionary setObject:forKey:]: attempt to insert nil key
  0  0x00007fff8a4e8cfa __exceptionPreprocess (in CoreFoundation)
  1  0x00007fff87bbd9ea objc_exception_throw (in libobjc.A.dylib)
  2  0x00007fff8a4e8b4a +[NSException raise:format:arguments:] (in CoreFoundatio

I have attached both logs to this e-mail.

This exception seems to be seen by many users unrelated to darwinbuild, but there doesn't seem to be a common known solution.

In another thread, Bill mentioned he has not tried Xcode 4.

I am wondering how I should tackle this.

A. Use Xcode 3.* instead of 4.1.  (Could you advise which 3.* I should use?)
B. Use a different build than 10J869 (Could you advise which build I should use?)
... Or some other approach?

Any advice shall be appreciated.

With best regards,


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macosforge.org/pipermail/darwinbuild-dev/attachments/20110531/d7e467a8/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: SmartCardServices-36160.log~1
Type: application/octet-stream
Size: 11817 bytes
Desc: SmartCardServices-36160.log~1
URL: <http://lists.macosforge.org/pipermail/darwinbuild-dev/attachments/20110531/d7e467a8/attachment-0002.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Tokend-40596.log~1
Type: application/octet-stream
Size: 11234 bytes
Desc: Tokend-40596.log~1
URL: <http://lists.macosforge.org/pipermail/darwinbuild-dev/attachments/20110531/d7e467a8/attachment-0003.obj>

More information about the darwinbuild-dev mailing list