<div>I&#39;ve actually tried to get this thing to build using the
suggestion of a UFS image. As stated in an earlier post, this failed
for me as well. If any has some relatively simple way to build this
thing, I&#39;d be willing to pay good money :) Also, I think building
&quot;libsecurity_utilties&quot; is a concern, that is if it hasn&#39;t been put up
in the roots area. <br><br>thanks,<br>jack<br>
</div><br><br><div class="gmail_quote"><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;"><br>
<br>
<br>
------------------------------<br>
<br>
Message: 2<br>
Date: Tue, 24 Jun 2008 12:13:59 +0200<br>
From: Bart Thissen &lt;<a href="mailto:bart@ardistech.com">bart@ardistech.com</a>&gt;<br>
Subject: Re: [darwinbuild-dev] No Xcode project?<br>
To: Mattias Br?ndstr?m &lt;<a href="mailto:mattias.brandstrom@todos.se">mattias.brandstrom@todos.se</a>&gt;<br>
Cc: <a href="mailto:darwinbuild-dev@lists.macosforge.org">darwinbuild-dev@lists.macosforge.org</a><br>
Message-ID: &lt;<a href="mailto:4860C8E7.90104@ardistech.com">4860C8E7.90104@ardistech.com</a>&gt;<br>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed<br>
<br>
It looks that Darwinbuild is more or less broken for the time<br>
beeing.... I had more luck with XCode (and spotlight to find the<br>
missing headers )<br>
<br>
Cheers,<br>
 &nbsp; &nbsp; &nbsp; &nbsp;Bart<br>
<br>
Mattias Br?ndstr?m wrote:<br>
&gt; Hello!<br>
&gt;<br>
&gt; There is probably something trivial I have missed, but I am having trouble building some projects with darwinbuild. I have set up the build directory according to the instructions in the README. When I do darwinbuild SmartCardServices everything seems to work at first, until I get this error message:<br>

&gt;<br>
&gt; xcodebuild: Error: the directory /SourceCache/SmartCardServices/SmartCardServices-32672 does not contain an Xcode project.<br>
&gt;<br>
&gt; This seems strange to me since the .tar.gz contains what looks like an Xcode project:<br>
&gt;<br>
&gt;&gt; tar tzvf Sources/SmartCardServices-32672.tar.gz | grep xcode<br>
&gt; drwxr-xr-x root/kevin &nbsp; &nbsp; &nbsp; &nbsp;0 2007-10-03 01:08:53 SmartCardServices-32672/SmartCardServices.xcodeproj/<br>
&gt; -rw-r--r-- root/kevin &nbsp; 145193 2007-10-03 01:08:53 SmartCardServices-32672/SmartCardServices.xcodeproj/project.pbxproj<br>
&gt;<br>
&gt; Perhaps someone on this list can see what might be wrong here?<br>
&gt;<br>
&gt; Regards,<br>
&gt; Mattias<br>
&gt; _______________________________________________<br>
&gt; darwinbuild-dev mailing list<br>
&gt; <a href="mailto:darwinbuild-dev@lists.macosforge.org">darwinbuild-dev@lists.macosforge.org</a><br>
&gt; <a href="http://lists.macosforge.org/mailman/listinfo.cgi/darwinbuild-dev" target="_blank">http://lists.macosforge.org/mailman/listinfo.cgi/darwinbuild-dev</a><br>
&gt;<br>
<br>
<br>
<br>
------------------------------<br>
<br>
Message: 3<br>
Date: Tue, 24 Jun 2008 07:09:24 -0700<br>
From: William Siegrist &lt;<a href="mailto:wsiegrist@apple.com">wsiegrist@apple.com</a>&gt;<br>
Subject: Re: [darwinbuild-dev] No Xcode project?<br>
To: Mattias Br?ndstr?m &lt;<a href="mailto:mattias.brandstrom@todos.se">mattias.brandstrom@todos.se</a>&gt;<br>
Cc: <a href="mailto:darwinbuild-dev@lists.macosforge.org">darwinbuild-dev@lists.macosforge.org</a><br>
Message-ID: &lt;<a href="mailto:51CA0C2C-C49F-4317-807C-6E448857AFF8@apple.com">51CA0C2C-C49F-4317-807C-6E448857AFF8@apple.com</a>&gt;<br>
Content-Type: text/plain; charset=&quot;iso-8859-1&quot;<br>
<br>
You&#39;re hitting &lt;<a href="http://darwinbuild.macosforge.org/trac/ticket/1" target="_blank">http://darwinbuild.macosforge.org/trac/ticket/1</a>&gt;. Its<br>
a known problem and I&#39;m still trying to fix it. The best workaround is<br>
to build on a UFS disk image. &nbsp;The basic problem is Xcode 3.0 has<br>
trouble inside of a chroot on certain filesystems, either because they<br>
support volfs, &nbsp;perhaps because they are case sensitive.<br>
<br>
Also make sure you&#39;ve installed from svn trunk as that has the Xcode 3<br>
support.<br>
<br>
<br>
-Bill<br>
<br>
<br>
<br>
On Jun 24, 2008, at 2:54 AM, Mattias Br?ndstr?m wrote:<br>
<br>
&gt; Hello!<br>
&gt;<br>
&gt; There is probably something trivial I have missed, but I am having<br>
&gt; trouble building some projects with darwinbuild. I have set up the<br>
&gt; build directory according to the instructions in the README. When I<br>
&gt; do darwinbuild SmartCardServices everything seems to work at first,<br>
&gt; until I get this error message:<br>
&gt;<br>
&gt; xcodebuild: Error: the directory /SourceCache/SmartCardServices/<br>
&gt; SmartCardServices-32672 does not contain an Xcode project.<br>
&gt;<br>
&gt; This seems strange to me since the .tar.gz contains what looks like<br>
&gt; an Xcode project:<br>
&gt;<br>
&gt;&gt; tar tzvf Sources/SmartCardServices-32672.tar.gz | grep xcode<br>
&gt; drwxr-xr-x root/kevin &nbsp; &nbsp; &nbsp; &nbsp;0 2007-10-03 01:08:53<br>
&gt; SmartCardServices-32672/SmartCardServices.xcodeproj/<br>
&gt; -rw-r--r-- root/kevin &nbsp; 145193 2007-10-03 01:08:53<br>
&gt; SmartCardServices-32672/SmartCardServices.xcodeproj/project.pbxproj<br>
&gt;<br>
&gt; Perhaps someone on this list can see what might be wrong here?<br>
&gt;<br>
&gt; Regards,<br>
&gt; Mattias<br>
&gt; _______________________________________________<br>
&gt; darwinbuild-dev mailing list<br>
&gt; <a href="mailto:darwinbuild-dev@lists.macosforge.org">darwinbuild-dev@lists.macosforge.org</a><br>
&gt; <a href="http://lists.macosforge.org/mailman/listinfo.cgi/darwinbuild-dev" target="_blank">http://lists.macosforge.org/mailman/listinfo.cgi/darwinbuild-dev</a><br>
<br>
<br>
<br>
<br>
----<br>
William Siegrist<br>
Mac OS Forge<br>
<a href="http://macosforge.org/" target="_blank">http://macosforge.org/</a><br>
<br>
<br>
</blockquote><br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;"><br>
<br>
<br>
<br>
<br>
-</blockquote></div><br>