Dominik Madon dominik at
Sun Oct 15 06:13:14 PDT 2006

> This is on a Macbook. I saw in the thread that your locale py- 
> package is installed, it's the C extension module that it can't  
> find. It should be in /opt/local/lib/python2.4/lib-dynload/ 
> Maybe yours have been misplaced somehow?

I've submitted a patch for the file but failed to add  
comments to the ticket (the site seems very busy).

The intl library that should be used to link the file was  
not properly detected. The line in the is:

          m ="#s*define\s+WITH_LIBINTL\s+1\s*", data)

and doesn't work for me since the pyconfig.h shows something like:

   #define HAVE_LIBINTL_H 1

So, I've just changed that line to:

          m ="#\s*define\s+(HAVE_LIBINTL_H|WITH_LIBINTL)\s 
+1\s*", data)

and I'm happy with it. However, I haven't checked why this works on  
my PPC box.

Thanks Daniel and Daniel for your help.


More information about the macports-dev mailing list