mp4v2, libmp4v2, and pango

Jeff Pitman jeff.pitman at
Wed Oct 7 05:31:19 PDT 2009

Hi again,
Back real quick with another problem with a recent selfupdate / upgrade
outdated. Macports at 1.8.1 and I have the following 2 problems doing
"upgrade outdated":

1. mp4v2 seems to replace libmp4v2, but faac and mpeg4ip still depend on
libmp4v2. So, when I execute "sudo port -u uninstall", it gives the
following error:

$ sudo port -u uninstall
--->  Unable to uninstall libmp4v2, the following ports depend on
--->    faac
--->    mpeg4ip
--->    faac
Error: port uninstall failed: Please uninstall the ports that depend on
libmp4v2 first.

Seems like these tickets are tracking this issue:

2. An older version of pango thinks it's newer than the real newer version
of pango.

$ sudo port upgrade outdated
--->  Computing dependencies for pango
--->  Fetching pango
--->  Verifying checksum(s) for pango
--->  Extracting pango
--->  Applying patches to pango
--->  Configuring pango
--->  Building pango
--->  Staging pango into destroot
--->  Deactivating pango @1.26.0_0+macosx
--->  Computing dependencies for pango
--->  Installing pango @1.24.5_0+macosx
--->  Activating pango @1.24.5_0+macosx
--->  Cleaning pango
$ sudo port activate pango
--->  The following versions of pango are currently installed:
--->    pango @1.24.5_0+macosx (active)
--->    pango @1.26.0_0+macosx
Error: port activate failed: Registry error: Please specify the full version
as recorded in the port registry.

I see this ticket describes a big problem with 1.26:

However, my gimp has been rendered completely unusable with the latest
upgrades. :(

Any tips appreciated!

take care,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list