Install Error

Bryan Blackburn blb at
Thu Oct 8 16:34:11 PDT 2009

On Thu, Oct 08, 2009 at 07:24:38PM -0400, Peter Hindrichs said:
> I am looking to further my understanding and knowledge of the command
> line and "Ports"  so when I tried to install the port "CosmicDebris"
> I got this message.
> I have tried to figure it out, but am having no luck, could someone
> please help me to understand what is actually being said here. Could
> this have something to do with the fact that the program is not Snow
> Leopard compatible  or is there another reason ?

That's entirely possible since it's wanting to build against the 10.4 SDK
which isn't installed by default with Xcode on 10.6 (if I recall correctly).
I also note that the current port version is 2.0 while there is an update
available, which notes "Version 2.1: Works with Mac OS X 10.5"...someone
needs to give the port an update at least.


> " returned error 1
> Command output:
> === BUILD NATIVE TARGET Cosmic Debris OF PROJECT Cosmic Debris WITH
> CONFIGURATION Deployment ===
> Check dependencies
> error: There is no SDK with the name or path '/Developer/SDKs/
> MacOSX10.4u.sdk'
> [BEROR]error: There is no SDK with the name or path '/Developer/SDKs/
> MacOSX10.4u.sdk'
> Error: Status 1 encountered during processing.
> Freedom:~ peterhin$
> Many Thanks
> Peter

More information about the macports-users mailing list