Install Error

Peter Hindrichs pth at
Thu Oct 8 19:50:51 PDT 2009

On 2009-10-08, at 22:00 , Ryan Schmidt wrote:

> On Oct 8, 2009, at 18:52, Peter Hindrichs wrote:
>> On 2009-10-08, at 19:37 , Lenore Horner wrote:
>>> I have 10.5 installed on my Mac.  I have both /Developer/SDKs/ 
>>> MacOSX10.4u.sdk and /Developer/SDKs/MacOSX10.5.sdk.  I have vague  
>>> memories that somewhere in installing developer tools I had a  
>>> choice about installing sdks.  Completely naively, I would have  
>>> expected Snow Leopard developer tools to install 10.4, 10.5, and  
>>> 10.6 sdks but maybe that doesn't work.  If you go back to your  
>>> installation disk do you have sdk installation options?
>> I checked the Install disk and I could not find any reference to  
>> sdk under optional installs.
> The 10.4u SDK is an optional not-installed-by-default option, in the  
> Xcode 3.2 installer. I specifically remember seeing it and selecting  
> it.

OK I found 10.4u SDK and installed it. This is what I get now when I  
try to do the install:

Freedom:~ peterhin$ sudo port install CosmicDebris
--->  Computing dependencies for CosmicDebris
--->  Building CosmicDebris
Error: Target returned: shell command " cd "/opt/ 
/work/CosmicDebrisSource" && /usr/bin/xcodebuild  -project "Cosmic  
Debris.xcodeproj" -target "Cosmic Debris"  -configuration Deployment "  
returned error 1
Command output:
=== BUILD NATIVE TARGET Cosmic Debris OF PROJECT Cosmic Debris WITH  
CONFIGURATION Deployment ===
Check dependencies
GCC 4.2 is not compatible with the Mac OS X 10.4 SDK (file main.m)
GCC 4.2 is not compatible with the Mac OS X 10.4 SDK (file main.m)

Error: Status 1 encountered during processing.
Freedom:~ peterhin$

Do the last few lines indicate that I need to get an earlier version  
of Gcc ?


More information about the macports-users mailing list