Error installing gcc41 on 10.6

Ryan Schmidt ryandesign at
Fri Oct 16 09:14:08 PDT 2009

On Oct 16, 2009, at 11:11, Bobby Williams wrote:

> On Oct 15, 2009, at 12:39 PM, Ryan Schmidt wrote:
>> On Oct 15, 2009, at 09:20, Bobby Williams wrote:
>>> Has anyone else encountered this?   Thanks!
>> Everybody who has tried this on Snow Leopard will have encountered  
>> this, yes. gcc43 is the earliest that builds on Snow Leopard at  
>> this time. There are tickets about these problems in the issue  
>> tracker, but they may not get fixed. These are very old versions of  
>> gcc. Is there a specific reason you want gcc41 and can't use e.g.  
>> gcc44?
> We have a large multi-platform (Linux(primary), Windows (secondary)   
> and OS/X (experimental) C++ project.   The Linux team uses gcc41.    
> gcc40 is used for building under OS/X.  We would like to simplify  
> things by normalizing compiler versions.    (That is, we'd like to  
> get rid of some the conditional compile stuff required because of  
> compiler differences.)

Note that Mac OS X (Tiger and later) does include gcc40 and (Leopard  
and later) gcc42 as part of Xcode, so if you can standardize on one of  
those versions, it's already there for you. Apple's gcc is of course  
different from the versions on other OSes. If you want to use plain  
gcc, you'll have to either use gcc43 or newer on Snow Leopard, or help  
us figure out how to make earlier gcc's compile again.

More information about the macports-users mailing list