Bad CPU type in executable

Dennis C dcswest at
Tue Oct 27 16:56:44 PDT 2009


Am in the process of making the switch from dual-boot PCs including FreeBSD,
so kind of new to this, but am now running Snow Leopard and one of the first
MacPorts I installed was psycopg2 and was able to run the python2.6 and
successfully import the aforementioned module, but now the following's

DCSs-Mac-mini:bin DCSWest$ python2.6
-bash: /opt/local/bin/python2.6: Bad CPU type in executable

So not quite sure what happened in between, but wondering if it wasn't
something with the following attempt to update software:

DCSs-Mac-mini:~ DCSWest$ sudo port selfupdate
--->  Updating the ports tree
--->  Updating MacPorts base sources using rsync
MacPorts base version 1.8.1 installed,
MacPorts base version 1.8.1 downloaded.
--->  MacPorts base is already the latest version

The ports tree has been updated. To upgrade your installed ports, you should
  port upgrade outdated

DCSs-Mac-mini:~ DCSWest$ sudo port upgrade outdated
--->  Computing dependencies for dbus
--->  Configuring dbus
Error: Target org.macports.configure returned: autoreconf failure: shell
command " cd
&& autoreconf --install " returned error 126
Command output: sh: /opt/local/bin/autoreconf: /opt/local/bin/perl: bad
interpreter: Bad CPU type in executable

Error: Unable to upgrade port: 1

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list