[macruby-changes] [4051] MacRuby/trunk/test_vm/exception.rb

source_changes at macosforge.org source_changes at macosforge.org
Fri May 7 20:53:10 PDT 2010


Revision: 4051
          http://trac.macosforge.org/projects/ruby/changeset/4051
Author:   martinlagardette at apple.com
Date:     2010-05-07 20:53:04 -0700 (Fri, 07 May 2010)
Log Message:
-----------
Add a test_vm for raise+ensure+return

Modified Paths:
--------------
    MacRuby/trunk/test_vm/exception.rb

Modified: MacRuby/trunk/test_vm/exception.rb
===================================================================
--- MacRuby/trunk/test_vm/exception.rb	2010-05-08 02:50:08 UTC (rev 4050)
+++ MacRuby/trunk/test_vm/exception.rb	2010-05-08 03:53:04 UTC (rev 4051)
@@ -397,3 +397,14 @@
   end
   foo
 }
+
+# Ensure should be called only once
+assert ":ok", %{
+  def foo
+    raise
+  ensure
+    p :ok
+    return true
+  end
+  foo
+}
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macosforge.org/pipermail/macruby-changes/attachments/20100507/d84dbace/attachment.html>


More information about the macruby-changes mailing list