[MacRuby-devel] [MacRuby] #482: Dispatch::Queue#dispatch should take a hash instead of a bool

MacRuby ruby-noreply at macosforge.org
Fri Dec 4 10:17:27 PST 2009


#482: Dispatch::Queue#dispatch should take a hash instead of a bool
----------------------------------------+-----------------------------------
 Reporter:  ernest.prabhakar@…          |       Owner:  lsansonetti@…        
     Type:  enhancement                 |      Status:  new                  
 Priority:  blocker                     |   Milestone:  MacRuby 0.5          
Component:  MacRuby                     |    Keywords:                       
----------------------------------------+-----------------------------------
 I like the way MacRuby unifies GCD's 'sync' and 'async' call into a single
 "dispatch" method.  However, I always need to remind myself which way is
 'true' and which is 'false'.  In addition, it may create ordering issues
 when we add other parameters.

 I think it would be better if dispatch just took an explicit hash; then we
 could say:

 q.dispatch(sync:true)

 which is much easier to figure out.  This would also simplify groups:

 q.dispatch(sync:true, group: g)

-- 
Ticket URL: <http://www.macruby.org/trac/ticket/482>
MacRuby <http://macruby.org/>



More information about the MacRuby-devel mailing list