[MacRuby-devel] [MacRuby] #415: Crash with "Call result #2 has unhandled type" trying to display a window

MacRuby ruby-noreply at macosforge.org
Sun Nov 1 02:43:12 PST 2009

#415: Crash with "Call result #2 has unhandled type" trying to display a window
 Reporter:  trejkaz@…              |       Owner:  lsansonetti@…        
     Type:  defect                 |      Status:  new                  
 Priority:  blocker                |   Milestone:                       
Component:  MacRuby                |    Keywords:                       
 I tried to run a trivial test application (straight from the MacRuby web
 page) and got a crash.  I have narrowed down the cause in the Ruby code:

 require 'hotcocoa'
 include HotCocoa
 application do |app|
   win = window :size => [100,50]    # commenting out this line makes it
 stay running

 I tried this on the 0.5 beta as well as the most recent nightly, getting
 the same result in both cases.

 Result of running this script:

 shard:test trejkaz$ macruby --version
 MacRuby version 0.5 (ruby 1.9.0) [universal-darwin10.0, i386]
 shard:test trejkaz$ macruby minimal.rb
 2009-11-01 21:41:12.508 macruby[17009:903] *** -[NSLock unlock]: lock
 (<NSLock: 0x2214830> '(null)') unlocked when not locked
 2009-11-01 21:41:12.512 macruby[17009:903] *** Break on _NSLockError() to
 Call result #2 has unhandled type f32UNREACHABLE executed at
 Stack dump:
 0.      Running pass 'X86 DAG->DAG Instruction Selection' on function
 Abort trap

 If this is really only happening to me, let me know what other information
 I can provide.

Ticket URL: <http://www.macruby.org/trac/ticket/415>
MacRuby <http://macruby.org/>

More information about the MacRuby-devel mailing list