[MacRuby-devel] How far away is Cucumber and RSpec support?

Laurent Sansonetti lsansonetti at apple.com
Sun Nov 22 17:15:27 PST 2009


Hi Giampiero,

The latest 0.5 beta doesn't run rspec, AFAIK. The rspec code is using  
too much dark magic that MacRuby can actually handle. Last time we  
check, we fail to run it because our #caller returns something  
different than the original Ruby.

We might eventually run rspec in the next beta. I heard they are  
cleaning the code at the moment so maybe we will run it, indirectly.

I know nothing about Cucumber support, yet. As usual, if you want to  
help, please try it, if it doesn't work, investigate why, reduce the  
problem and file a Trac report :-)

Laurent

On Nov 21, 2009, at 12:17 PM, Giampiero De Ciantis wrote:

> I know the topic of RSpec support has come up before, specifically  
> about why it doesn't function. Does anyone know if the fixes in the  
> 0.5 release will cover those issues? Or is this something of 0.6?
>
> Cheers,
>
> -Gp
> _______________________________________________
> MacRuby-devel mailing list
> MacRuby-devel at lists.macosforge.org
> http://lists.macosforge.org/mailman/listinfo.cgi/macruby-devel



More information about the MacRuby-devel mailing list