[MacRuby-devel] Building MacRuby r2765 with llvm r82747 failed on core duo macbook, Leopard

Laurent Sansonetti lsansonetti at apple.com
Fri Oct 9 16:46:19 PDT 2009


On Oct 9, 2009, at 4:22 AM, hiroshi saito wrote:

> Hi all,
> I failed to build llvm r82747 and MacRuby r2765 following the
> instruction of README.
> I use core duo macbook and Leopard.
> $ svn co -r 2765
> http://svn.macosforge.org/repository/ruby/MacRuby/trunk MacRuby-trunk
> $ svn co -r 82747 https://llvm.org/svn/llvm-project/llvm/trunk llvm- 
> trunk
> $ cd llvm-trunk
> ...
> llvm[2]: Compiling BasicBlockTracing.c for Release build (bytecode)
> ...
> llvm-gcc-4.2: -E, -S, -save-temps and -M options are not allowed with
> multiple -arch flags

Looks like the LLVM build system it picking llvm-gcc instead of gcc.  
This is probably why it's failing.

You probably want to remote llvm-gcc out of your $PATH and try again.

> To avoid the error, omited univsersal environment variables.
> It worked.
> Next, build MacRuby itself. My llvm isn't universal binary anymore, so
> I explicitly specified archs options;
> $ PATH=$PATH:~/Desktop/wc/MacRuby/llvm-trunk/Release/bin rake  
> archs=i386
> ...
> /usr/bin/g++ -I/Users/hiroshi/Desktop/wc/MacRuby/llvm-trunk/include
> -I/Users/hiroshi/Desktop/wc/MacRuby/llvm-trunk/include  -D_DEBUG
> -fno-common -Woverloaded-virtual -I. -I./include -g -Wall -arch i386
> -Wno-parentheses -Wno-deprecated-declarations -Werror -Winline --param
> inline-unit-growth=10000 --param large-function-growth=10000 -x
> objective-c++ -c dispatcher.cpp -o dispatcher.o
> cc1objplus: warnings being treated as errors
> /Users/hiroshi/Desktop/wc/MacRuby/llvm-trunk/include/llvm/Type.h:417:
> warning: ‘void llvm::PATypeHandle::addUser()’ was used before it was
> declared inline

Mmh, this never happened to me. But I never tried to build MacRuby for  
a single architecture like this yet.

I recommend to rebuild LLVM without llvm-gcc and try again.

Good luck,


More information about the MacRuby-devel mailing list