[Xquartz-dev] Re: Xquartz-1.3.0-apple3

Ben Byer bbyer at apple.com
Fri Dec 7 16:08:37 PST 2007

"Cool" -- this still reproduces for me even with alloca disabled.

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_PROTECTION_FAILURE at address: 0x00062a24
[Switching to process 79040 thread 0x3203]
0x00098715 in fbBltOne (src=0x16a55740, srcStride=<value temporarily  
unavailable, due to optimizations>, srcX=7, dst=0x62a24,  
dstStride=<value temporarily unavailable, due to optimizations>,  
dstX=16672, dstBpp=32, width=32, height=1, fgand=4278190080, fgxor=0,  
bgand=4278190080, bgxor=16776960) at fbbltone.c:371
371					*dst = FbStippleRRop (*dst, mask,
(gdb) print src
$1 = (FbStip *) 0x16a55740
(gdb) print *src
$2 = 60
(gdb) print dst
$3 = (FbBits *) 0x62a24

So, fbBltOne is trying to write out too many bits.  I ran into this  
bug a lot in the Tiger version, and did a lot of digging to isolate  
the cause -- only to discover that it was a known issue.  They never  
found the problem, but somewhere around 1.2 they put the following  
workaround in:

185	    /*
186	     * Do not read past the end of the buffer!
187	     */
188	    srcEnd = src + height * srcStride;

... hm ... maybe we need something similar for dst?

On Dec 7, 2007, at 2:25 PM, Jeremy Huddleston wrote:

> I'll put out a version with alloca disabled for you to test in a bit.
> --Jeremy
> On Dec 7, 2007, at 14:11, Simone Karin Lehmann wrote:
>> Am 06.12.2007 um 05:15 schrieb Jeremy Huddleston:
>>> I've just pushed Xquartz-1.3.0-apple3 to the server and source  
>>> code is uploading now.  wiki will be updated soon.
>>> Pretty much the only change users will notice over 1.3.0-apple2  
>>> (from X11- is a hook to disable fbBlah calls.  If you  
>>> have been experiencing crashes in fbFill or other calls that start  
>>> with fb, then try this out and let us know how it works for you:
>>> Start Terminal.app and  execute:
>>> $ touch /tmp/disable_fb.txt
>>> Now launch X and try to crash it.
>> This doesn't work for me.
>> I've tried it and I can still get X to crash in fbBlah routines.
>> I'm using Gimp. You can download it from http://gimp.lisanet.de/Website/Gimp_unter_Mac_OS_X_files/Gimp%202.4.2%20Leopard.dmg
>> Now open an image with big dimensions. Mine is a 3474x2314 tiff  
>> image.
>> Duplicate the background layer twice by clicking on the duplicate  
>> layer icon in gimp's toolbox window.
>> Now click on the menu text in the image window _without_ first  
>> clicking on the image window's title bar.
>> Crash.
>> Works every time :-(
>> FYI: I use the click_trough feature of quartz_wm.
>> Simone
>> -- 
>> in the arms of your angel, you may find some comfort here.
> _______________________________________________
> Do not post admin requests to the list. They will be ignored.
> X11-users mailing list      (X11-users at lists.apple.com)
> Help/Unsubscribe/Update your Subscription: http://lists.apple.com/mailman/options/x11-users/bbyer%40apple.com
> This email sent to bbyer at apple.com

Ben Byer
CoreOS / BSD Technology Group, XDarwin maintainer

More information about the Xquartz-dev mailing list