[Xquartz-dev] 2.3.0-rc3

Vincent Noel vincent.noel at gmail.com
Tue Jun 3 23:46:59 PDT 2008


I have noticed a weird problem that has started with the 2.3.0 rc3 update:

I usually connect from my mac to a linux machine through ssh, from
where I ssh again
to a third linux machine to do actual work (the 3rd machine only
allows inbound connections
from the second one). Until now, X requests were always correctly
forwarded back to the local machine (ie I've always been able to open
X applications on the 3rd machine and they showed up correctly on my
local display, sorry if I'm not using the appropriate terms).
With the rc3, I can't do this anymore -- I get an error message on the
3rd machine telling me the X display cannot be opened (the message
says something like "cannot open display on localhost:12.0").

I've just tried this from another mac that hasn't been upgraded to
rc3, and it works fine, so nothing has changed on the remote machines
(the 3rd machine sets DISPLAY to localhost:10.0 if that's any help).

The weird part is that X applications open fine when I launch them on
the second machine...

I've tried rebooting and trashing the X preferences file, but it doesn't help.
This is on an MBP with 10.5.3. Everything works as expected apart from that.


On Wed, Jun 4, 2008 at 2:29 AM, Jeremy Huddleston
<jeremyhu at freedesktop.org> wrote:
> So... I assume the silence is good news?  Could I atleast get a few
> "works for me here" replies so I know that someone other than me is
> using it and you all haven't lost faith in my betas ;)
> --Jeremy
> On May 30, 2008, at 10:18, Jeremy Huddleston wrote:
>> I've uploaded a new release candidate for 2.3.0.  I've been using this
>> for about a week now and feel comfortable enough about it to put it
>> out "in the wild" to let you all mess with it while I move on to the
>> next stage of the startup rewrite.  Major changes since 2.3.0-rc2:
>> Pulled in proper xkeyboard-config data instead of xkbdata (this should
>> get Xfake and Xephyr to work without needing the '-kb' command line
>> option)
>> Reverted Xquartz to not use xkb since we don't actually have a quartz
>> keyboard xkb data file (not sure the best way to solve this, I'm going
>> to leave this headache for post-2.3.0)
>> Xquartz now has the capability to add a new $DISPLAY socket after the
>> server is started (rather than only at start).  This is needed for the
>> new OSX-friendly startup method that I'm working on.  We use this now
>> just within the server itself, but in rc4, I expect the socket will be
>> handed off to the server by the stub.
>> Please test it out and let me know of any regressions.
>> http://xquartz.macosforge.org/downloads/X11-2.3.0_rc3.pkg
>> Note, I consider this fairly stable and regression free at this point,
>> but there are bound to be some issues that arise.  Now that I have
>> this out, I'm going to be working on some things that are a bit more
>> fragile, so if you want to balance "works" with "testing", this should
>> be a fairly safe beta for you.  Of course, I may end up eating these
>> words later...
>> --Jeremy
>> _______________________________________________
>> Xquartz-dev mailing list
>> Xquartz-dev at lists.macosforge.org
>> http://lists.macosforge.org/mailman/listinfo.cgi/xquartz-dev
> _______________________________________________
> Xquartz-dev mailing list
> Xquartz-dev at lists.macosforge.org
> http://lists.macosforge.org/mailman/listinfo.cgi/xquartz-dev

More information about the Xquartz-dev mailing list