[Xquartz-dev] 2.3.0-rc3

John Koren jpkoren at gmail.com
Wed Jun 4 19:34:59 PDT 2008

I have just experienced the same problem using 2.3.0-rc3 and it was a
direct ssh to a remote machine.
The  DISPLAY on the remote was set to 10.0.
Starting a new connection to the same machine fixed the problem.

I have "Authorize network client connections" checked, so that's not
the reason for this unstable ssh behavior.
It could be also related to the latest  OSX 10.5.3 update, which I
installed at the same time as 2.3.0-rc3.

Cheers -John

>Ok, I just checked "Authorize network client connections" in the X preferences
>(not sure the exact wording in english) and it now works fine. Not sure why this
>option was unchecked in the first place. Weird.
>Sorry for the noise.
On Wed, Jun 4, 2008 at 12:36 PM, Merle Reinhart <merlereinhart at
mac.com> wrote:
> I just tried it from my mac, ssh -Y to a solaris 10 machine, then ssh -
> Y to another solaris 10 machine (I don't have linux boxes readily
> available).  X11 displayed back just fine whether X11 was started on
> the Mac prior to the ssh's or if the final ssh produces the request to
> start X11.
> Merle
> On Jun 4, 2008, at 6:17 AM, Vincent Noel wrote:
>> FWIW, when I follow the steps outlined below with the rc3, I get
>> $ nedit
>> Xlib: connection to "localhost:16.0" refused by server
>> Xlib: Invalid MIT-MAGIC-COOKIE-1 key
>> NEdit: Can't open display
>> still working fine with previous X (rc2 was working fine IIRC).
>> Cheers
>> V
>> On Wed, Jun 4, 2008 at 8:46 AM, Vincent Noel
>> <vincent.noel at gmail.com> wrote:
>>> Hello,
>>> I have noticed a weird problem that has started with the 2.3.0 rc3
>>> update:
>>> I usually connect from my mac to a linux machine through ssh, from
>>> where I ssh again
>>> to a third linux machine to do actual work (the 3rd machine only
>>> allows inbound connections
>>> from the second one). Until now, X requests were always correctly
>>> forwarded back to the local machine (ie I've always been able to open
>>> X applications on the 3rd machine and they showed up correctly on my
>>> local display, sorry if I'm not using the appropriate terms).
>>> With the rc3, I can't do this anymore -- I get an error message on
>>> the
>>> 3rd machine telling me the X display cannot be opened (the message
>>> says something like "cannot open display on localhost:12.0").
>>> I've just tried this from another mac that hasn't been upgraded to
>>> rc3, and it works fine, so nothing has changed on the remote machines
>>> (the 3rd machine sets DISPLAY to localhost:10.0 if that's any help).
>>> The weird part is that X applications open fine when I launch them on
>>> the second machine...
>>> I've tried rebooting and trashing the X preferences file, but it
>>> doesn't help.
>>> This is on an MBP with 10.5.3. Everything works as expected apart
>>> from that.
>>> Cheers,
>>> Vincent

More information about the Xquartz-dev mailing list