[Xquartz-dev] libXdamage, compatibility version 3.0.0

Simone Karin Lehmann simone at lisanet.de
Tue Jan 6 22:49:24 PST 2009


I'm providing pre-build packages of GIMP on the GIMP on OS X website.

With the latest build (GIMP 2.6.4) I got a lot of complaints from  
users about GIMP not starting. This is the error message:

Dyld Error Message:
Library not loaded: /usr/X11/lib/libXdamage.1.dylib
Referenced from: /tmp/skl/Gimp.app/Contents/Resources/lib/libgtk- 
Reason: Incompatible library version: libgtk-x11-2.0.0.dylib requires  
version 3.0.0 or later, but libXdamage.1.dylib provides version 2.0.0

I've compiled GIMP with XQuartz, which provides the correct  
libXdamage version. But users who have version prior to 2.3.2 will get  
this error about an incompatible library.

How can I avoid this problem? Which version of XQuartz do I have to  
install, to get libXdamage with compatibility version 2.0.0? Will a  
GIMP build with such an old XQuartz still run on or later? Any  
other suggestions to solve this conflict?


More information about the Xquartz-dev mailing list