[Xquartz-dev] Building on Snow Leopard?

Jeremy Huddleston jeremyhu at apple.com
Thu Sep 10 18:52:41 PDT 2009


On Sep 10, 2009, at 15:29, Pelle Johansson wrote:

> Hi,
>
> maybe a bit lazy for just asking instead of trying, but is there any  
> (easy) way to build the X server on Snow Leopard right now, or  
> should I just wait to download 2.4.1 first? I have a few local  
> patches I'd like to get back in my server...

All of the necessary changes have been pushed into git over the past  
week or two.  Right now, I'm battling a bug in xcode or the kernel or  
perl or something which is preventing the build script from running  
correctly.  I was hoping to have a 2.4.1 alpha out last weekend, but  
that hasn't happened.  Hopefully I will be able to work out these  
weird issues over the next week or so and get something into  
everyone's hands.

> On that topic (patches), one of them is this one:
>
> diff --git a/hw/xquartz/xpr/xprScreen.c b/hw/xquartz/xpr/xprScreen.c
> index 1fac9ec..9448e0c 100644
> --- a/hw/xquartz/xpr/xprScreen.c
> +++ b/hw/xquartz/xpr/xprScreen.c
> @@ -155,7 +155,7 @@ displayScreenBounds(CGDirectDisplayID id)
>             (int)frame.origin.x, (int)frame.origin.y);
>
>   /* Remove menubar to help standard X11 window managers. */
> -    if (quartzEnableRootless &&
> +    if (!quartzHasRoot &&
>       frame.origin.x == 0 && frame.origin.y == 0) {
>       frame.origin.y += aquaMenuBarHeight;
>       frame.size.height -= aquaMenuBarHeight;
>
> Those variables are named a bit confusing

Yeah... and perhaps I should do a big search/replace on them... don't  
look at me, I inherited them that way ;)

IIRC: quartzEnableRootless is the variable that toggles the mode.  Are  
we rootless or are we fullscreen (the preference option).   
quartzHasRoot is the variable that essentially corresponds to the (for  
lack of better name) cmd-alt-a state.

> , but I finally decided that quartzHasRoot is the variable deciding  
> if the server is currently in full screen mode.
> Can anyone else verify that this is a correct change? Pasted from  
> terminal so might not be applicable directly...

quartzEnableRootless is actually the right variable here.  If we are  
in rootless mode, we want our display to subtract off the menu bar.   
If we are in fullscreen mode (regardless of whether or not we are  
actively displaying X11), we want the menu bar region to be part of  
our X11 screen.

What is the behavior issue that you are seeing that you are trying to  
fix?



More information about the Xquartz-dev mailing list