[CalendarServer-dev] [CalendarServer] #356: Unable to start CalendarServer on Suse

CalendarServer trac at macosforge.org
Sat Jan 2 12:38:59 PST 2010

#356: Unable to start CalendarServer on Suse
 Reporter:  tillz@…          |       Owner:  wsanchez@…        
     Type:  Defect           |      Status:  new               
 Priority:  5: Not set       |   Milestone:  Linux Port        
Component:  Calendar Server  |    Severity:  Other             
 Keywords:                   |  

Comment(by armin.kraetschmer@…):

 Replying to [ticket:356 tillz@…]:
 > Hello, I'm unable to start the Calendarserver. krb5-config can't be
 > [...]


 I can confirm this behaviour. Installed DCS on Gentoo (x86_64,
 2.6.31-gentoo-r6), when I tried to start it I got the same error message.

 Fact is: the cause for this is a missing kerberos/PyKerberos install
 (kerberos/PyKerberos is not needed for DCS to work and I don't want/need
 kerberos on my home server). The ''krb5-config: not found'' thing can be
 ignored, as it's just a check, if kerberos is available (in this case it
 is not). If this check (located in the support/build.sh script, line 438)
 fails, the setup for the PyKerberos package won't be downloaded and run
 (as it is not needed for a system without kerberos).

 My workaround for getting the server to work anyway: just comment the
 ''import kerberos'' directive in twistedcaldav/authkerb.py, line 41. After
 commenting the line, the server runs without any problems. Maybe you also
 have to ensure that the kerberos authentication in conf/caldavd-dev.xml is
 deactivated (per default it is; haven't tested, if it causes any problems
 when active).

 Hope this helps a little. Greetings, Armin

Ticket URL: <http://trac.calendarserver.org/ticket/356#comment:1>
CalendarServer </>

More information about the calendarserver-dev mailing list