[CalendarServer-users] UTF-8 Encoding Problem

Cyrus Daboo cdaboo at apple.com
Fri Dec 8 06:22:30 PST 2006

Hi Frank,

--On December 8, 2006 11:47:26 AM +0100 Frank Strauß 
<strauss at ibr.cs.tu-bs.de> wrote:

>> This is a bug in Mulberry - its not sending utf-8 as it should, but
>> instead iso-8859-1 or something. I guess I will kick the Mulberry person
>> and get them to fix it :-)
> Hi Cyrus,
> thanks for your quick response.
> I'm not completely sure, but I don't think it's a bug in Mulberry. I
> recoded Mulberry's request myself and could not find any problems. Then I
> tried Mozilla Sunbird and had the same problem: pure ASCII requests work
> fine, umlauts in the SUMMARY (or elsewhere?) raise the same error on the
> server. The encoding of the same three umlauts results in the same six
> UTF-8 octets.
> Here is the "Ethereal Follow TCP Stream" output of both requests. (Sorry
> for any inconvenience due to this message's "flowed" format.) Note the
> different Content-Type values and the different line breaks (0x0a in
> Mulberry, 0x0d 0x0a in Sunbird), though the raised error is the same.
> I do not yet have an iCal3 to play with. Can you suggest any other
> clients I could try and compare?

I did do some more investigation and it is a server problem. I added a 
ticket for it and will fix fairly soon:


Cyrus Daboo

More information about the calendarserver-users mailing list