[CalendarServer-users] iCal can no longer see server's calendars

Daniele Procida procida at cf.ac.uk
Fri Aug 13 01:58:59 PDT 2010

Until yesterday, my server worked perfectly well.

I use one user, called home, which has a number of calendars.

Yesterday they all disappeared from iCal. iCal can still connect, and create and find new calendars and events. This affects every machine I try to connect to the server with.

I can see all the calendars at :8008/calendars/users/home/ on the server, and the events in them, but only ones I have created since yesterday are visible in iCal. I'd really love to get the old ones back!

Since I can see the data on the server it seems to me that a pointer to it has become corrupted. I can't see any obvious file permissions problems.

If I run props in the runshell utility, I get a list of OK properties followed by:

> Failed Properties:
>     {DAV:}acl: 401
>     {DAV:}current-user-privilege-set: 401

I don't know if that is significant.

Finally, I built the WebDAVBrowser utility to see if that would reveal anything more, but when I run it I get a message:

> WebDAVBrowser Error
> An unexpected error has occurred during execution of the main script
> NibLoaderError: Invalid NIB file [/Users/daniele/Desktop/CalDAVClientLibrary/dist/WebDAVBrowser.app/Contents/Resources/WebDAVBrowser.nib]

I'd be most grateful for any tips on how to continue investigating this.

Daniele Procida
Web Officer
Cardiff University School of Medicine
Tel.: +44 29 2074 2144

More information about the calendarserver-users mailing list