[CalendarServer-users] unable to install calendarserver

Emmanuel Bourreau ebourreau at nordnet.fr
Fri Feb 17 02:08:14 PST 2017

as usual, you’re right !
But I have another problem
After bin/run -n…

Starting server...
Reading configuration from file: /Users/emmanuel/CalendarServer2/master/conf/caldavd-dev.plist
2017-02-17T10:51:17+0100 [twistedcaldav.upgrade#info] Converting augments.xml
2017-02-17T10:51:17+0100 [twistedcaldav.upgrade#info] Converting augments.xml
2017-02-17T10:51:17+0100 [calendarserver.tap.caldav.CalDAVServiceMaker#info] Calendar and Contacts Server 9.1b1.dev0+7c50b666693493196e6c3df59811063ef7368d97 starting Combined process...
2017-02-17T10:51:17+0100 [twistedcaldav.localization#info] Looking for Apple .lproj directories in locales
2017-02-17T10:51:17+0100 [twisted.scripts._twistd_unix.UnixAppLogger#info] twistd 16.6.0 (/Users/emmanuel/CalendarServer2/master/.develop/virtualenv/bin/python 2.7.10) starting up.
2017-02-17T10:51:17+0100 [twisted.scripts._twistd_unix.UnixAppLogger#info] reactor class: twisted.internet.selectreactor.SelectReactor.
2017-02-17T10:51:17+0100 [-] AMPPushNotifierFactory starting on 62311
2017-02-17T10:51:17+0100 [-] ControlSocket starting on './data/Logs/state/caldavd.sock'
2017-02-17T10:51:17+0100 [txdav.base.datastore.subpostgres#info] Cluster already exists at /Users/emmanuel/CalendarServer2/master/data/Data/Database/cluster
2017-02-17T10:51:17+0100 [txdav.base.datastore.subpostgres#info] Requesting postgres start via: ['/Users/emmanuel/CalendarServer2/master/.develop/roots/PostgreSQL/bin/pg_ctl', 'start', '--log=/Users/emmanuel/CalendarServer2/master/data/Logs/postgres.log', '--timeout=86400', '-w', '-o', "-c listen_addresses='' -c unix_socket_directories=/tmp/ccs_postgres_bfc609ea6b4ff8bf216572903d163531 -c shared_buffers=139 -c max_connections=93 -c standard_conforming_strings=on -c unix_socket_permissions=0770 -c log_line_prefix=%t"]
2017-02-17T10:51:17+0100 [memcached-Default] dyld: lazy symbol binding failed: Symbol not found: _clock_gettime
2017-02-17T10:51:17+0100 [memcached-Default]   Referenced from: /Users/emmanuel/CalendarServer2/master/.develop/roots/libevent/lib/libevent-2.0.5.dylib (which was built for Mac OS X 10.12)
2017-02-17T10:51:17+0100 [memcached-Default]   Expected in: /usr/lib/libSystem.B.dylib
2017-02-17T10:51:17+0100 [memcached-Default] dyld: Symbol not found: _clock_gettime
2017-02-17T10:51:17+0100 [memcached-Default]   Referenced from: /Users/emmanuel/CalendarServer2/master/.develop/roots/libevent/lib/libevent-2.0.5.dylib (which was built for Mac OS X 10.12)
2017-02-17T10:51:17+0100 [memcached-Default]   Expected in: /usr/lib/libSystem.B.dylib
2017-02-17T10:51:17+0100 [txdav.base.datastore.subpostgres.PostgresMonitor#info] waiting for server to start....
2017-02-17T10:51:18+0100 [txdav.base.datastore.subpostgres.PostgresMonitor#info]  stopped waiting
2017-02-17T10:51:18+0100 [txdav.base.datastore.subpostgres.PostgresMonitor#error] pg_ctl: could not start server
2017-02-17T10:51:18+0100 [txdav.base.datastore.subpostgres.PostgresMonitor#error] Examine the log output.
2017-02-17T10:51:18+0100 [txdav.base.datastore.subpostgres.PostgresMonitor#info] pg_ctl process ended with status=256
2017-02-17T10:51:18+0100 [txdav.base.datastore.subpostgres.PostgresMonitor#error] Could not start postgres; see postgres.log
2017-02-17T10:51:18+0100 [txdav.base.datastore.subpostgres#critical] Can't start or connect to postgres: No such socket file: /tmp/ccs_postgres_bfc609ea6b4ff8bf216572903d163531/.s.PGSQL.5432
2017-02-17T10:51:18+0100 [-] (UNIX Port ./data/Logs/state/caldavd.sock Closed)
2017-02-17T10:51:18+0100 [-] (TCP Port 62311 Closed)

And the server doesn’t start. Or I think so, because i can’t connect with Safari on localhost:8008 or 8443.
I remember I had same problem but can’t remember how i've solved it.
Furthermore : Is it a good idea to use bin/run -n at each startup of my computer ?

> Le 17 févr. 2017 à 03:33, Andre LaBranche <dre at apple.com> a écrit :
> Hi,
> Try deleting the "localhost" cert from your keychain (using /Applications/Utilities/Keychain). I've seen this problem a few times but am still not sure exactly how it happens - possibly CalendarServer has lost access privs to a keychain item that was previously stashed there. Deleting will allow new items to be created.
> Alternatively, you can delete the .develop directory then "export USE_OPENSSL=1" and re-run bin/develop to disable use of SecureTransport, which includes disabling the use of keychain to store the server's private key.
> -dre
> On Feb 16, 2017, at 3:30 PM, Emmanuel Bourreau <ebourreau at nordnet.fr <mailto:ebourreau at nordnet.fr>> wrote:
>> Hello,
>> during the bin/develop, i have the following error
>> Keychain init.
>> Could not find identity 'org.calendarserver.test'
>> Found certificate 'localhost'
>> Traceback (most recent call last):
>>   File "bin/keychain_init.py", line 164, in <module>
>>     identityCreate()
>>   File "bin/keychain_init.py", line 67, in identityCreate
>>     raise RuntimeError(error if error else output)
>> RuntimeError: security: No matching identity found for "localhost"
>> Next, if i try a « bin/run -n » 
>> i obtain
>> The configured TLS Keychain Identity (Keychain: org.calendarserver.test) cannot be used: Unable to load Keychain identity: org.calendarserver.test
>> System : 10.11.6
>> Calendarserver 9.1 
>> Can you help me ?
>> Thanks
>> Emmanuel
>> _______________________________________________
>> calendarserver-users mailing list
>> calendarserver-users at lists.macosforge.org <mailto:calendarserver-users at lists.macosforge.org>
>> https://lists.macosforge.org/mailman/listinfo/calendarserver-users <https://lists.macosforge.org/mailman/listinfo/calendarserver-users>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.macosforge.org/pipermail/calendarserver-users/attachments/20170217/28a178e8/attachment-0001.html>

More information about the calendarserver-users mailing list