[darwinbuild] perl 5.8.1 (perl-25.2)

Dale Walsh dale at daleenterprise.com
Wed Nov 30 03:46:03 PST 2005

While I build the Perl software I'm experiencing an issue that  
involves setrgid and setruid not being implemented.

I've tried editing the hints.append file with no success.

Seems that this isn't being supported for some reason however I'm not  
experiencing any build problems.

As a side test, I tried building the Perl for 10.4 under 10.3.9 and  
it builds without issue but also experiences the same problem with  
setrgid and setruid.

Going a step further, I substituted 5.8.6 with 5.8.7, tar'd it back  
up and this built without problems but also experiences the setrgid  
and setruid problem.

One thing I did notice when I upped the perl to 5.8.7 was that it  
warned about two patches which seemed to already be applied but this  
was the only issue that was reported and no build errors were  

I made a minor change to the patch file and this resolved the warning  
about a previously applied patch.

I then installed OSXS 10.4, upgraded to 10.4.3 and tried to build the  
perl software and it seems that it also suffers the same problem with  
setrgid and setruid.

I've checked unistd.h in both the 7W98 and 8C47 and the entries exist  
for these functions so I'm not sure what's causing the problem.

Also, under 10.3.9 I am unable to build darwinbuild-0.7.x due to a  
redefinition and a conflict of types for readlink.

-- Dale

More information about the darwinbuild-dev mailing list