[darwinbuild-dev] Missing Availability.h with 9G55

Craig Setera craigjunk at setera.org
Tue Apr 28 11:40:51 PDT 2009

I feel like I'm *so close* doing this via darwinbuild, but I'm still  
hitting problems. I will do some more digging on the troubleshooting  
page to see if I can resolve the issues I'm seeing now.  I tried to  
specify the target and it complained that that target didn't exist, so  
I'm not sure what is going on there.

It looks like some of this may be failing when trying to build for  
PPC.  I really only care about intel, so I'm not sure if there is an  
easy way to disable targeting PPC?

Mig /SourceCache/ppp/ppp-314.0.1/Controller/pppcontroller.defs
     mkdir "/private/var/tmp/ppp/ppp-314.0.1.obj/ppp.build/pppd  
     cd /SourceCache/ppp/ppp-314.0.1
     /XCD/loper/usr/bin/mig -header "/private/var/tmp/ppp/ 
ppp-314.0.1.obj/ppp.build/pppd (Tool).build/DerivedSources/ 
pppcontroller.h" -user "/private/var/tmp/ppp/ppp-314.0.1.obj/ppp.build/ 
pppd (Tool).build/DerivedSources/pppcontrollerUser.c" -sheader /dev/ 
null -server /dev/null -I/private/var/tmp/ppp/ppp-314.0.1.sym/ 
BuiltProducts/include -I../../Family -I/private/var/tmp/ppp/ 
ppp-314.0.1.root/usr/include /SourceCache/ppp/ppp-314.0.1/Controller/ 
dyld: Library not loaded: /System/Library/Frameworks/ 
   Referenced from: /usr/bin/arch
   Reason: image not found
cc: Invalid arch name : -D__MACH30__
mig: fatal: "<no name yet>", line -1: no SubSystem declaration
rmdir: /tmp/mig.FDBFhh: No such file or directory

I may also have to step back and try XCode with a specific target again.


On Apr 28, 2009, at 1:11 PM, Stuart Crook wrote:

> Hi, Craig.
> If you're still tryind darwinbuild, "darwinbuild -target=pppd ppp"  
> should (although I haven't tried it) build just the pppd part of the  
> ppp package, which will at least save you having to chase down non- 
> relevant problems.
> _sjc_
> On 28 Apr 2009, at 18:18, Craig Setera wrote:
>> Stuart,
>> I tried that route originally and couldn't seem to get things  
>> going.  I grabbed configd for those particular headers and then  
>> that required more headers...  Maybe the issue was that I was  
>> trying to build "all" rather than just pppd?  My C skills are rusty  
>> (I'm primarily a Java guy).  To top it off, my Mac OS X/Darwin  
>> skills are non-existent.  This is all good learning for me in the  
>> end...
>> I will see whether I can get one or both of these options going  
>> (Darwin Build or XCode build).
>> Thanks,
>> Craig
>> On Apr 28, 2009, at 11:22 AM, Stuart Crook wrote:
>>> Hi, Craig,
>>> Since pppd is an XCode project, you may find it easier to build it  
>>> there, patching as needed, rather than in darwinbuild. There are  
>>> lost of sub-projects inside it, but when I tried just the pppd  
>>> target a minute ago it only threw up 4 errors (compared to about a  
>>> thousand for the whole lot).
>>> (Or rather, two errors repeated: it couldn't find  
>>> SystemConfiguration/SCPrivate.h (which you can get from its  
>>> source) or ppp/pppcontroller_types.h (which I think should be in  
>>> this package). )
>>> You will certainly run into fewer problems because of missing non- 
>>> open frameworks. But this is only a suggestion, your milage may  
>>> vary, etc..
>>> _sjc_
>>> On 28 Apr 2009, at 17:01, Craig Setera wrote:
>>>> Thanks.  I will take a look.  This is truly a geeky endeavor.  I  
>>>> have a new Blackberry Bold that I want to use as a Bluetooth  
>>>> tethered modem.  Myself and others are having trouble.  I think  
>>>> it is in the ppp negotiation and I'm trying to build ppp so that  
>>>> I can use it with various hacks to try to tether.  A long way to  
>>>> go for something so silly, but it is really bugging me now!
>>>> So, in a nutshell, I'd like to be able to build and execute a  
>>>> custom pppd on my Macbook Pro (10.5.6).  Any hints or pointers  
>>>> are greatly appreciated.
>>>> Thanks,
>>>> Craig
>>>> On Apr 28, 2009, at 10:57 AM, Stuart Crook wrote:
>>>>> Hi, Craig.
>>>>> You may find the answer here: http://www.puredarwin.org/developers/darwinbuild/troubleshooting 
>>>>>  -- or elsewhere on the site. There are also patches for various  
>>>>> packages in the svn at code.google.com/p/puredarwin .
>>>>> Which bits of Darwin in particular are you interested in /  
>>>>> trying to build?
>>>>> _sjc_
>>>>> On 28 Apr 2009, at 16:47, Craig Setera wrote:
>>>>>> Continuing to make progress thanks to your help.  I loaded CF  
>>>>>> and Security and managed to get further.  Now I'm seeing:
>>>>>> In file included from /System/Library/Frameworks/ 
>>>>>> Security.framework/Headers/Security.h:50,
>>>>>>            from /SourceCache/ppp/ppp-314.0.1/Helpers/pppd/ 
>>>>>> auth.c:2764:
>>>>>> /System/Library/Frameworks/Security.framework/Headers/SecBase.h: 
>>>>>> 63: error: syntax error before 'SecKeychainAttrType'
>>>>>> The source code in that header is:
>>>>>> typedef OSType SecKeychainAttrType;
>>>>>> Any idea where OSType would be declared?  Also, what is the  
>>>>>> difference between doing "darwinbuild CF" rather than  
>>>>>> "darwinbuild -load CF"?  I had done the former, but it required  
>>>>>> the latter.
>>>>>> Thanks again,
>>>>>> Craig
>>>>>> On Apr 27, 2009, at 9:46 PM, William Siegrist wrote:
>>>>>>> On Apr 27, 2009, at 7:40 PM, Craig Setera wrote:
>>>>>>>> I'm still new to darwinbuild and running into a problem that  
>>>>>>>> I don't understand.  It appears that I have the problem  
>>>>>>>> discussed and resolve in this trac ticket:  http://darwinbuild.macosforge.org/trac/ticket/58 
>>>>>>>>  .  I have a build root using 9G55 and can even see the  
>>>>>>>> correct CarbonHeaders in the 9G55.plist file:
>>>>>>>>        CarbonHeaders = {
>>>>>>>>                 version = 9G55;
>>>>>>>>         };
>>>>>>>> Unfortunately, references to stdlib.h and stat.h are causing  
>>>>>>>> errors referring to Availability.h and I'm not sure what  
>>>>>>>> might be going on or how I might be able to fix it:
>>>>>>>> In file included from /SourceCache/ppp/ppp-314.0.1/Helpers/ 
>>>>>>>> pppd/ccp.c:60:
>>>>>>>> /usr/include/stdlib.h:61:26: error: Availability.h: No such  
>>>>>>>> file or directory
>>>>>>>> In file included from /SourceCache/ppp/ppp-314.0.1/Helpers/ 
>>>>>>>> pppd/ccp.c:60:
>>>>>>>> /usr/include/stdlib.h:283: error: syntax error before  
>>>>>>>> Can anyone provide guidance on how to solve this problem?
>>>>>>> For now, you can manually load a root for CarbonHeaders with  
>>>>>>> the following:
>>>>>>> darwinbuild -load CarbonHeaders
>>>>>>> I'll update the dependencies for ppp so its loaded  
>>>>>>> automatically in the future.
>>>>>>> Thanks
>>>>>>> -Bill
>>>>>> _______________________________________________
>>>>>> darwinbuild-dev mailing list
>>>>>> darwinbuild-dev at lists.macosforge.org
>>>>>> http://lists.macosforge.org/mailman/listinfo.cgi/darwinbuild-dev
>>>> _______________________________________________
>>>> darwinbuild-dev mailing list
>>>> darwinbuild-dev at lists.macosforge.org
>>>> http://lists.macosforge.org/mailman/listinfo.cgi/darwinbuild-dev

More information about the darwinbuild-dev mailing list