[darwinbuild-dev] Missing Availability.h with 9G55

Craig Setera craigjunk at setera.org
Wed Apr 29 14:16:00 PDT 2009

Fix one thing and find the next :-)  Looks like now it is choking on  
missing IOKit headers?  I did a load of "IOKitTools" which worked, but  
it didn't help.  I tried "IOKitUser" which I saw in the plist files,  
but that one came up as a missing root.  Looking at the  
troubleshooting, there is discussion of building IOKitUser.  Will that  
get me what I need?  Is there a place on my Mac I can copy what I need  
into my build root?

Thanks yet again,

On Apr 29, 2009, at 1:34 AM, William Siegrist wrote:

> On Apr 28, 2009, at 7:14 PM, Craig Setera wrote:
>> First, let me thank you for helping out so much as I try to make  
>> this work.  The fact that I'm trying to do this "for fun" probably  
>> tells you a bit about how geeky I really am.  It appears that I'm  
>> down to a single remaining error:
>> Mig /SourceCache/ppp/ppp-314.0.1/Controller/pppcontroller.defs
>>   mkdir "/private/var/tmp/ppp/ppp-314.0.1.obj/ppp.build/pppd  
>> (Tool).build/DerivedSources"
>>   cd /SourceCache/ppp/ppp-314.0.1
>>   /XCD/loper/usr/bin/mig -header "/private/var/tmp/ppp/ 
>> ppp-314.0.1.obj/ppp.build/pppd (Tool).build/DerivedSources/ 
>> pppcontroller.h" -user "/private/var/tmp/ppp/ppp-314.0.1.obj/ 
>> ppp.build/pppd (Tool).build/DerivedSources/pppcontrollerUser.c" - 
>> sheader /dev/null -server /dev/null -I/private/var/tmp/ppp/ 
>> ppp-314.0.1.sym/BuiltProducts/include -I../../Family -I/private/var/ 
>> tmp/ppp/ppp-314.0.1.root/usr/include /SourceCache/ppp/ppp-314.0.1/ 
>> Controller/pppcontroller.defs
>> dyld: Library not loaded: /System/Library/Frameworks/ 
>> CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/ 
>> Versions/A/CFNetwork
>> Referenced from: /System/Library/Frameworks/Foundation.framework/ 
>> Versions/C/Foundation
>> Reason: image not found
>> cc: Invalid arch name : -D__MACH30__
>> mig: fatal: "<no name yet>", line -1: no SubSystem declaration
>> rmdir: /tmp/mig.C5pcvL: No such file or directory
>> Is this related to the architecture comment at the bottom of this  
>> email chain?  If so, can you give me some insight into how to go  
>> about altering things appropriately?

More information about the darwinbuild-dev mailing list