realpath failed -- error uninstalling ports

Dexter Douglas luomo1138 at
Fri Oct 2 16:31:18 PDT 2009


I am sorry.  I left out ALL the important information.

I am running Leopard on a PowerBook G4; Xcode 3.1.2; macports 1.8.1.

"port uninstall" was working just fine until 1 Oct.  That is when I performed a selfupdate to 1.8.1 and then upgraded all my outdated ports.

After the upgrade, I tried to clean up by uninstalling the inactive ports.  That is when I got the error message. 

I have two most likely unrelated pieces of information.
1) During the upgrading, doxygen failed to compile.  I ended up uninstalling and trying to reinstall.  I was not able to reinstall doxygen.  2) I suffered from the "MacPorts 1.8.0 deletes ${prefix} if it is a symlink" problem (


--- On Fri, 10/2/09, Ryan Schmidt <ryandesign at> wrote:

> From: Ryan Schmidt <ryandesign at>
> Subject: Re: realpath failed -- error uninstalling ports
> To: "Dexter Douglas" <luomo1138 at>
> Cc: macports-users at
> Date: Friday, October 2, 2009, 12:11 AM
> On Oct 1, 2009, at 22:27, Dexter Douglas wrote:
> > I get this error message when I try to uninstall
> inactive ports:
> > 
> > Error: port uninstall failed: realpath failed: No such
> file or directory
> > 
> > Does anyone know what this means?
> This happens on every port? Has it always been this way or
> did it recently start? If the latter, what changed?
> What version of Mac OS X, Xcode, MacPorts? What Mac?


More information about the macports-users mailing list