[MacRuby-devel] Framework callbacks in macirb

Laurent Sansonetti lsansonetti at apple.com
Mon Feb 9 11:24:47 PST 2009


Barry,

MacRuby trunk builds in 64-bit by default, so I suspect that here  
VersaPHY.framework has only been built for 32-bit only.

Try to load macirb for i386 first and see if you can load your  
framework:

$ arch -i386 /usr/local/bin/macirb

It is good practice since Leopard to build your own code for both 32- 
bit and 64-bit mode.

Laurent

On Feb 9, 2009, at 11:17 AM, Barry Walker wrote:

> Thanks again for the help.  I macraked the trunk and hotconsole and  
> it worked, sort of.
>
> With the trunk build, my framework won't load.
>
> >> framework 'VersaPHY'
> 2009-02-09 12:04:12.258 macruby[35283:10b] Error loading /Users/ 
> barry/Library/Frameworks/VersaPHY.framework/VersaPHY:  dlopen(/Users/ 
> barry/Library/Frameworks/VersaPHY.framework/VersaPHY, 265): no  
> suitable image found.  Did find:
>     /Users/barry/Library/Frameworks/VersaPHY.framework/VersaPHY:  
> mach-o, but wrong architecture
>     /Users/barry/Library/Frameworks/VersaPHY.framework/VersaPHY:  
> mach-o, but wrong architecture
> RuntimeError: framework at path `/Users/barry/Library/Frameworks/ 
> VersaPHY.framework' cannot be loaded: Error  
> Domain=NSCocoaErrorDomain Code=3585 UserInfo=0x80041d900 "The bundle  
> "VersaPHY" could not be loaded because it does not contain a version  
> for the current architecture." (dlopen_preflight(/Users/barry/ 
> Library/Frameworks/VersaPHY.framework/VersaPHY): no suitable image  
> found.  Did find:
>     /Users/barry/Library/Frameworks/VersaPHY.framework/VersaPHY:  
> mach-o, but wrong architecture
>     /Users/barry/Library/Frameworks/VersaPHY.framework/VersaPHY:  
> mach-o, but wrong architecture)
>     from (irb):1:in `framework'
>     from (irb):1
>     from /usr/local/bin/macirb:12:in `<main>'
>
> I reloaded 0.3 and:
>
> Macintosh:MacRuby-0.3 barry$ macirb
> >> framework 'VersaPHY'
> => true
>
> Is this broken on purpose?
>
> Regards,
> Barry
>
>
> On Sun, Feb 8, 2009 at 1:14 AM, Vincent Isambart <vincent.isambart at gmail.com 
> > wrote:
> > Macintosh:vincentisambart-hotconsole- 
> cbdd6d06ece482e124516359cd9299294667daeb barry$ macrake
> > (in /Users/barry/dev/vincentisambart-hotconsole- 
> cbdd6d06ece482e124516359cd9299294667daeb)
> > rake aborted!
> > no such file to load -- hotcocoa/standard_rake_tasks
> > /Users/barry/dev/vincentisambart-hotconsole- 
> cbdd6d06ece482e124516359cd9299294667daeb/rakefile:2:in `require'
> > (See full trace by running task with --trace)
>
> This means you are using an old version of MacRuby, probably 0.3. You
> can check it by running macruby -v, or in macirb by displaying
> MACRUBY_VERSION and MACRUBY_REVISION.
> _______________________________________________
> MacRuby-devel mailing list
> MacRuby-devel at lists.macosforge.org
> http://lists.macosforge.org/mailman/listinfo.cgi/macruby-devel
>
> _______________________________________________
> MacRuby-devel mailing list
> MacRuby-devel at lists.macosforge.org
> http://lists.macosforge.org/mailman/listinfo.cgi/macruby-devel

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macosforge.org/pipermail/macruby-devel/attachments/20090209/c450e104/attachment-0001.html>


More information about the MacRuby-devel mailing list