[MacRuby-devel] Framework callbacks in macirb

Barry Walker bwalker at quantumparametrics.com
Mon Feb 9 12:58:52 PST 2009

As usual your insight is spot on.  I tested the -i386 switch and it worked,
then I rebuild the framework for 64-bit and that also worked.

Unfortunately, the initial goal of permitting callbacks to the framework
during execution is still not met by HotConsole.  HotConsole seems to act
exactly like macirb.  Callbacks are not executed.  Calling
NSApplication.sharedApplication.run from HotConsole is a big mistake.

Thanks for all the hand holding anyway.


On Mon, Feb 9, 2009 at 12:24 PM, Laurent Sansonetti
<lsansonetti at apple.com>wrote:

> Barry,
> MacRuby trunk builds in 64-bit by default, so I suspect that here
> VersaPHY.framework has only been built for 32-bit only.
> Try to load macirb for i386 first and see if you can load your framework:
> $ arch -i386 /usr/local/bin/macirb
> It is good practice since Leopard to build your own code for both 32-bit
> and 64-bit mode.
> Laurent
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macosforge.org/pipermail/macruby-devel/attachments/20090209/09992d4e/attachment.html>

More information about the MacRuby-devel mailing list