[MacRuby-devel] Saving MacRuby Project fails to start in xcode

Joshua Ballanco jballanc at gmail.com
Fri Jan 23 01:16:31 PST 2015

Hi Don,

Unfortunately, the MacRuby project is currently in an inactive/un-maintained state. A number of changes introduced starting with OS X Lion made the work of maintaining MacRuby increasingly difficult. This includes changes to both the Cocoa libraries as well as Xcode. RubyMotion exists as an option should you desire to build a native app completely in Ruby, and there is also RubyCocoa if all you need is to interface with some Cocoa libraries.



On January 23, 2015 at 01:44:39, don (mclamb.donald at gmail.com) wrote:


I am getting an error when attempting to start a MacRuby project in Xcode. 
I tried to report a bug with apple for Xcode and they suggested it was an issue with my macruby. 
It has never worked as this was the first time that I was going to use it. 

I go through the normal process of starting a OS X project of mac ruby and when I go to save my git directory it errors out. I have an error log but it is to big to attach. If there is additional information requiired please let me know and I will provide. 

Any advise or help would be appreciated. 

thanks don 
MacRuby-devel mailing list 
MacRuby-devel at lists.macosforge.org 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.macosforge.org/pipermail/macruby-devel/attachments/20150123/f865b2af/attachment.html>

More information about the MacRuby-devel mailing list