[Xquartz-dev] The 2.1.0 package and Apple System Fonts

Merle Reinhart merlereinhart at mac.com
Sun Dec 9 07:34:44 PST 2007

On Dec 9, 2007, at 3:10 AM, Martin Costabel wrote:

> Ben Byer wrote:
>> On Dec 8, 2007, at 6:24 PM, Merle Reinhart wrote:
> []
>>> I played with this some more doing what you did above.  Then  
>>> looking at the Fink applesystemfonts package, there is a comment  
>>> there that the .dfonts have to be converted to .ttf to work with  
>>> X11 (they use their fondu package to do this).  I installed this  
>>> package, but they weren't seen by xlsfonts.
> The applesystemfonts package is old, of course. It was made be Ben  
> Reed long before Apple even had an X11 package. It has evolved  
> since, but it would happily cede its place to a built-in  
> functionality of Apple's X11.
> []
>>> Unfortunately, when I restart the server, I then have to readd the  
>>> Fink path with the converted fonts (this may be something for  
>>> my .xinitrc or is there somewhere better to put this?).
> In principle, the Fink xfontpath package should make this happen  
> automatically for you. This worked on Tiger at shell startup by  
> checking whether your DISPLAY was :0 and then running xset +fp. On  
> Leopard it couldn't be left to run xset at every shell startup,  
> because this would then wake up launchd and start X11 every time,  
> even if you don't want it. So you need to run it by hand, but you  
> don't need to remember the path (which can be more complex if you  
> add some of the other Fink X font packages like msttcorefonts or x- 
> ghostscript-fonts or xfonts-intl). You can just run
> xfontpath enable
> This will run xset +fp with the right arguments. If you don't mind  
> running X11 all the time, you can put this into your shell startup  
> scripts.
>> Theoretically, you should be able to create a /usr/X11/lib/X11/ 
>> xorg.conf file and add these settings there, but that file doesn't  
>> seem to be read by our server, and I'm not sure why.   It's easy to  
>> add to the font path when recompiling Xquartz, however.
>> If it's not clear, I'm trying to render applesystemfonts  
>> pointless. :)
> Good, one package less to maintain for me :-)

I put "/sw/bin/xfontpath enable" in my ~/.xinitrc and that worked very  
well.  Thanks Martin for the hint.

So, this is a very good workaround for me until Xquartz can assume the  
System font paths entirely.  Thanks Ben. :-)


-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 2425 bytes
Desc: not available
Url : http://lists.macosforge.org/pipermail/xquartz-dev/attachments/20071209/4c8981da/smime-0001.bin

More information about the Xquartz-dev mailing list