[Xquartz-dev] libXdamage, compatibility version 3.0.0

Simone Karin Lehmann simone at lisanet.de
Tue Jan 6 23:48:49 PST 2009

Am 07.01.2009 um 08:42 schrieb Jeremy Huddleston:

> If you want your app to run on earlier versions, you need to use the  
> 10.5 (or 10.4u) SDK.

Does that mean that I have to install the XQuartz version shipped with  
10.5.3 (or was it 10.5.2)? How can I do this? Will those builds still  
run on XQuartz 2.3.2+ ?


> On Jan 6, 2009, at 22:49, Simone Karin Lehmann wrote:
>> Hi,
>> I'm providing pre-build packages of GIMP on the GIMP on OS X website.
>> With the latest build (GIMP 2.6.4) I got a lot of complaints from  
>> users about GIMP not starting. This is the error message:
>> Dyld Error Message:
>> Library not loaded: /usr/X11/lib/libXdamage.1.dylib
>> Referenced from: /tmp/skl/Gimp.app/Contents/Resources/lib/libgtk- 
>> x11-2.0.0.dylib
>> Reason: Incompatible library version: libgtk-x11-2.0.0.dylib  
>> requires version 3.0.0 or later, but libXdamage.1.dylib provides  
>> version 2.0.0
>> I've compiled GIMP with XQuartz, which provides the correct  
>> libXdamage version. But users who have version prior to 2.3.2 will  
>> get this error about an incompatible library.
>> How can I avoid this problem? Which version of XQuartz do I have to  
>> install, to get libXdamage with compatibility version 2.0.0? Will a  
>> GIMP build with such an old XQuartz still run on or later?  
>> Any other suggestions to solve this conflict?
>> -skl

More information about the Xquartz-dev mailing list