[Xquartz-dev] libXdamage, compatibility version 3.0.0
jeremyhu at apple.com
Tue Jan 6 23:55:42 PST 2009
On Jan 6, 2009, at 23:48, Simone Karin Lehmann wrote:
> Am 07.01.2009 um 08:42 schrieb Jeremy Huddleston:
>> If you want your app to run on earlier versions, you need to use
>> the 10.5 (or 10.4u) SDK.
> Does that mean that I have to install the XQuartz version shipped
> with 10.5.3 (or was it 10.5.2)? How can I do this? Will those builds
> still run on XQuartz 2.3.2+ ?
How are you building all the dependencies? Are you using fink?
macports? by hand?
If you build against the 10.4u SDK, it will work on 10.4, 10.5, and
any version from http://xquartz.macosforge.org.
If you build against 10.5 SDK, it will not work on 10.4, but will work
on any version of 10.5.x and any version from http://xquartz.macosforge.org
If you build against the system version installed with 10.5.x, it will
not be guaranteed to work on versions of OSX less than 10.5.x (meaning
if you build with 10.5.5, it won't be guaranteed to work on 10.5.4).
If you build against the system version after installing an update, it
will not be guaranteed to work on earlier versions of the update.
This is the whole reason for providing the /Developer/SDKs/...
More information about the Xquartz-dev