[Xquartz-dev] Problems with xorg-server-devel @1.17.0_0 and xorg-server-devel @1.17.1_0 on PPC Mac OS X 10.5.8, Leopard

Jeremy Huddleston Sequoia jeremyhu at apple.com
Sat Mar 14 21:02:31 PDT 2015

> On Mar 14, 2015, at 14:08, Peter Dyballa <Peter_Dyballa at Web.DE> wrote:
> Am 10.03.2015 um 04:36 schrieb Jeremy Huddleston Sequoia:
>> git://people.freedesktop.org/~jeremyhu/xserver
> This URI worked fine. I then tried to use your compile from five years ago to build the X server. With some small changes (for example to build a pure PPC binary, updated paths to find modern xorg-macros) it could build the X server, for which I also had to rename /usr/sbin/dtrace because LD was not able to handle the DOF (?) section or table. I then invoked 'make install', but this installed X server does seem to launch.
>>> And what happens after cloning the X server? How does it get built and installed?
>> If you can't figure out how to build it from the checkout, just use the Portfile per my instructions in a previous email ... just using the checkout to figure out what commit to test next.
> I am not able to determine which instructions you mean. Could you give me the date of sending or could you copy an paste them?

Here they are reposted:

That means it was something between:
git commits cff12936275db2f71f6d24f9ea0985a0d14af454 and e572bcc7f4236b7e0f23ab762f225b3bce37db59

If you are not comfortable building from a git checkout, I suggest you stay at the checkout and bisect between those to git commits by editing the git.branch line of the Portfile to figure out what commit introduced the issue.

You can do something like:

git clone ssh://git.freedesktop.org/git/xorg/xserver.git
cd xserver
git bisect start
git bisect bad e572bcc7f4236b7e0f23ab762f225b3bce37db59
git bisect good cff12936275db2f71f6d24f9ea0985a0d14af454

It will then report something like this:

Bisecting: 169 revisions left to test after this (roughly 8 steps)
[35dc7c75150733dbcef8a18b6796f49a7c48ebee] Merge branch 'modesetting-import' into master

So try 35dc7c75150733dbcef8a18b6796f49a7c48ebee and then run 'git bisect good' or 'git bisect bad' as appropriate and try the next one until you've determined what commit introduced the problem.


More information about the Xquartz-dev mailing list