[Xquartz-dev] XQuartz 2.7.10_beta1

Tom Lane tgl at sss.pgh.pa.us
Tue May 17 14:40:32 PDT 2016

Jeremy Huddleston Sequoia <jeremyhu at apple.com> writes:
> I have just released XQuartz 2.7.10_beta1.  The only changes from 2.7.9 are updates to mesa 11.2.1 and xorg-server 1.18.3.  Note that as with the 2.7.9 betas, this version is built with ASan which will help with error reporting but may have a negative impact on performance.

I tried 2.7.10_beta1 for a couple of days, and gave up because of this
odd behavior:

When attempting "ulimit -c unlimited" in bash running in an xterm window
under beta1, I get a "permission denied" type of error (don't have the
exact wording handy).  It appears that something in beta1 is forcing the
hard limit for core size down to zero for subprocesses of an xterm.  This
doesn't happen in 2.7.9, nor when running bash under Terminal.  Possibly
it's a side effect of ASan, but if so, it's one that I've not seen in
previous versions, and it makes XQuartz next to unusable for my daily
development work.

Another thing I ran into is that when keeping an X11-aware build of Emacs
open within my XQuartz sessions, I find it disappears from the screen
after allowing my laptop to sleep and wake from sleep.  The emacs process
is still there according to ps, and its window is still listed in
XQuartz's Window menu, but I can't see it, nor pull it up using the Window
menu item.  I've now found that I can reproduce this in 2.7.9 as released,
though I'm sure it was not happening last time I tried to do this a few
months ago.  (I might still have been on Yosemite at that point, not
sure.  Normally I do this with a remote emacs, which hasn't shown any
sign of trouble --- it's only emacs running locally on my laptop that
is problematic.)  Any ideas about debugging that, or a workaround?

			regards, tom lane

More information about the Xquartz-dev mailing list