[CalendarServer-users] HTTP 404 problems

Rasmus Borup Hansen rbh at intomics.com
Thu Apr 26 00:08:32 PDT 2012

On Apr 25, 2012, at 17:57 , Chris Cleeland wrote:

> I will simply echo that I'm having similar problems using the dpkg of 2.4.  I've narrowed it down to requested items not being found in memcached, but the fact that I am a crappy python programmer combined with the fact that getting calendarserver is NOT part of my day job, I have been unable to dig in any further and come up with a cause.
> I've posted questions on the topic on this mailing list a couple of times that didn't bear much fruit.   Maybe together we can figure this out?
> One thing that may be relevant is that the 2.4 package of calendarserver runs against the standard memcached installation.  I know that there are some packages that calendarserver sucks in and modifies, and I do not know if memcached is one of those.  Maybe a developer can answer this question?  Can we run calendarserver--any version--against a standard memcached distribution?

I tried disabling memcached with the configuration below (setting the key ClientEnabled to false) and stopping the memcached that comes with Ubuntu. I still get random 404s, so I think there's more to it than just problems with memcached.

    <!-- Memcache Settings -->

In addition, I get a lot of the following errors:

2012-04-26 09:04:06+0200 [-] [caldav-0]  [-] [twext.web2.dav.http#info] 404 response while getting property: ('http://calendarserver.org/ns/', 'getctag')
2012-04-26 09:04:06+0200 [-] [caldav-0]  [-] [twext.web2.dav.http#info] 404 response while getting property: ('DAV:', 'sync-token')

Are they related?

Best regards,


Hansen, Rasmus Borup              Intomics - from data to biology
System Administrator              Diplomvej 377
Scientific Programmer             DK-2800 Kgs. Lyngby
E: rbh at intomics.com               W: http://www.intomics.com/
P: +45 5167 7972                  P: +45 8880 7979

More information about the calendarserver-users mailing list