[CalendarServer-users] problem with osxframeworks

Emmanuel Bourreau ebourreau at nordnet.fr
Wed Aug 17 12:53:26 PDT 2016

Hi Cyrus
with your explanations, "bin/develop" worked
But,(yes I know, i’m a pain in the neck), "run -n" doesn’t work

I obtain the following lines

Mac-Pro:ccs-calendarserver-master emmanuel$ bin/run -n
Using /Users/emmanuel/Downloads/ccs-calendarserver-master/.develop/virtualenv/bin/python as Python

Starting server...
Reading configuration from file: /Users/emmanuel/Downloads/ccs-calendarserver-master/conf/caldavd-dev.plist
Created directory: ./data/Data
Created directory: ./data/Data/Documents
Created directory: ./data/Logs
Created directory: ./data/Logs/state
2016-08-17T21:37:20+0200 [twistedcaldav.upgrade#info] Converting augments.xml
2016-08-17T21:37:20+0200 [twistedcaldav.upgrade#info] Converting augments.xml
2016-08-17T21:37:20+0200 [calendarserver.tap.caldav.CalDAVServiceMaker#info] Calendar and Contacts Server 9.1a1+unknown starting Combined process...
2016-08-17T21:37:20+0200 [twistedcaldav.upgrade#info] Converting augments.xml
2016-08-17T21:37:20+0200 [twisted.scripts._twistd_unix.UnixAppLogger#info] twistd 16.3.0 (/Users/emmanuel/Downloads/ccs-calendarserver-master/.develop/virtualenv/bin/python 2.7.5) starting up.
2016-08-17T21:37:20+0200 [twisted.scripts._twistd_unix.UnixAppLogger#info] reactor class: twisted.internet.selectreactor.SelectReactor.
2016-08-17T21:37:20+0200 [-] AMPPushNotifierFactory starting on 62311
2016-08-17T21:37:20+0200 [-] ControlSocket starting on './data/Logs/state/caldavd.sock'
2016-08-17T21:37:20+0200 [txdav.base.datastore.subpostgres#info] Creating /Users/emmanuel/Downloads/ccs-calendarserver-master/data/Data/Database
2016-08-17T21:37:20+0200 [txdav.base.datastore.subpostgres#info] Creating /Users/emmanuel/Downloads/ccs-calendarserver-master/data/Data/Database/working
2016-08-17T21:37:20+0200 [txdav.base.datastore.subpostgres#info] Running initdb for /Users/emmanuel/Downloads/ccs-calendarserver-master/data/Data/Database/cluster
2016-08-17T21:37:23+0200 [txdav.base.datastore.subpostgres#info] Requesting postgres start via: ['/Users/emmanuel/Downloads/ccs-calendarserver-master/.develop/roots/PostgreSQL/bin/pg_ctl', 'start', '--log=/Users/emmanuel/Downloads/ccs-calendarserver-master/data/Logs/postgres.log', '--timeout=86400', '-w', '-o', "-c listen_addresses='' -c unix_socket_directories=/tmp/ccs_postgres_daf9bdc6ecae3d1f1054251743039b99 -c shared_buffers=139 -c max_connections=93 -c standard_conforming_strings=on -c unix_socket_permissions=0770 -c log_line_prefix=%t"]
2016-08-17T21:37:23+0200 [txdav.base.datastore.subpostgres.PostgresMonitor#info] waiting for server to start....
2016-08-17T21:37:24+0200 [txdav.base.datastore.subpostgres.PostgresMonitor#info]  done
2016-08-17T21:37:24+0200 [txdav.base.datastore.subpostgres.PostgresMonitor#info] server started
2016-08-17T21:37:24+0200 [txdav.base.datastore.subpostgres.PostgresMonitor#info] pg_ctl process ended with status=0
2016-08-17T21:37:24+0200 [txdav.base.datastore.subpostgres#info] /Users/emmanuel/Downloads/ccs-calendarserver-master/.develop/roots/PostgreSQL/bin/pg_ctl exited
2016-08-17T21:37:26+0200 [txdav.base.datastore.subpostgres#critical] Can't start or connect to postgres: Incorrect root element: accounts
2016-08-17T21:37:26+0200 [txdav.base.datastore.subpostgres#info] Requesting postgres stop via: ['/Users/emmanuel/Downloads/ccs-calendarserver-master/.develop/roots/PostgreSQL/bin/pg_ctl', 'stop', '--log=/Users/emmanuel/Downloads/ccs-calendarserver-master/data/Logs/postgres.log']
2016-08-17T21:37:26+0200 [-] (UNIX Port ./data/Logs/state/caldavd.sock Closed)
2016-08-17T21:37:26+0200 [-] (TCP Port 62311 Closed)
2016-08-17T21:37:26+0200 [txdav.base.datastore.subpostgres.PostgresMonitor#info] waiting for server to shut down....
2016-08-17T21:37:27+0200 [txdav.base.datastore.subpostgres.PostgresMonitor#info]  done
2016-08-17T21:37:27+0200 [txdav.base.datastore.subpostgres.PostgresMonitor#info] server stopped
2016-08-17T21:37:27+0200 [txdav.base.datastore.subpostgres.PostgresMonitor#info] pg_ctl process ended with status=0
2016-08-17T21:37:27+0200 [-] Main loop terminated.
2016-08-17T21:37:27+0200 [twisted.scripts._twistd_unix.UnixAppLogger#info] Server Shut Down.

More over, if i copy Data from my old calendarserver to the new, it says that it is not compatible :-( 
because postgresql moved from 9.0 to 9.5
I’ve seen something about pg_dumpall but where it is in my old calendar server ?

A lot of work remains!
Best regards 

Le 17 août 2016 à 20:24, Cyrus Daboo <cdaboo at apple.com> a écrit :

> Hi Emmanuel,
> --On August 17, 2016 at 11:52:03 AM +0200 Emmanuel Bourreau <ebourreau at nordnet.fr> wrote:
>> My « very old » Mac Pro is under 10.9.5
>> I’ve followed your instructions and saved the output to a file
>> I’ve removed the part where it installs Postgresql even if I read lots
>> « nothing to be done » and « ld warning » about lib and lib64
> Yup - that OS version is a little too old. I did try forcing it to use OpenSSL instead of SecureTransport, but even the modern version of that failed to build.
> If you are really unable to upgrade the OS (to at least 10.11) and you really are OK with using the built-in version of openssl (which lacks fixes for some of the newer SSL bugs), then you may be able to get it to build by making the following changes:
> 1) rm -rf .develop
> 2) export USE_OPENSSL=1
> 3) Edit bin/_build.sh, change:
>   local min_ssl_version="268443791";  # OpenSSL 1.0.2h
> to:
>   local min_ssl_version="9470383";  # OpenSSL 0.9.8
> I tried it with those changes on 10.9.5 and it seemed to work.
> -- 
> Cyrus Daboo

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.macosforge.org/pipermail/calendarserver-users/attachments/20160817/a1067157/attachment.html>

More information about the calendarserver-users mailing list